Ring Peephole Stuck in a boot loop

Good Morning!

I received my brand new Ring Peephole yesterday and set everything up.

The camera was working perfectly fine last night, but when i tried checking in on it this morning it would not connect. The doorbell itself is not functioning and there’s a flashing blue light every 1 second. It has been doing this for the past 3 hours now.

I have checked the forum, watched youtube videos and tried all of the troubleshooting suggestions, but nothing seems to be working. I made an attempt on resetting the device by holding the orange button for over 30 seconds and then waiting for 5 minutes for it to boot up, However it would only flash a blue light for 1 second and then be off for 1 second. This process would continue itself endlessley. I have tried connecting 2 different phones to the device, both an Iphone and an android, however both seem to not be working.

I have tried several hard resets on the device without any luck. The Location of the router is less than 6 feet from the doorbell.

Kind Regards,


There were several Motion Detection notifications from last night which have been saved. Majority of this footage was pitch black and showed us nothing. Now, Whenever I try to connect with the live view, It will not “activate” the device and will give me the message: " **Failed to connect. ** We are having trouble connecting to your ring doorbell". In the history of the camera it will say that there was a live view, But when opening this it will show a black screen.

Hey @JK-Libao. Thank you for taking the time to detail all the work you have done to try to get this to work! Since you have gone as far as trying to reset the device and reconnect it to still no avail, it would be best to follow up with our support team on on this concern. Please read our response to COVID-19 hereto see how to contact support. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times.

Hi there,
I’ve also been having the same problem as you and have tried absolutely everything.
Have you managed to resolve the issue? If so, can you let me know what you did please? I’m losing the will to live trying to get it to work! Thanks in advance

I understand how frustrating it is.
I ended up calling costumer service and explained the situation to them.

We ended up receiving a replacement unit free of charge. I would highly recommending giving them a call to fix the situation!

I hope it gets resolved soon!

1 Like

I installed it yesterday and it did captured couple of motion video and it stopped and any motion or live video is black ! It will recognize motion and take video but taking black video same with Live !

Sad truth is just installed yesterday and ran into issue in few hours. Technical support is joke !

This is seems like known issue as i ran into same. Did it started working? what solution they provided?