Ring Password either works on App or Website, but not both....

So I setup Ring on Android Phone, all was working fine… I attempted to access account on website and it said password was wrong… I finally gave up and just reset password…now I can sign into website, but cannot sign in (with new credentials) on phone. <BIG SIGH>

I would ensure that you are typing in your password correct @CNK . Also, do you have Two-factor Authentication? Finally, have you tried uninstalling and reinstalling the Ring app?

LOL, yeah tried all of that.

I suggest reaching out to our Support team who will be able to take a further look into this for you.

It has been a month since you first posted your issue so I don’t know if you are still having the issue, but after dealing with the same problem for over an hour (saying password was wrong on app and website, even tho I know it was correct), I finally figured it out! You cannot use the autofill when you enter your email address. You have to type in the whole email address every time. I’m not sure why it doesn’t like the autofill, I just know that typing it out has worked every time on multiple devices!

2 Likes