Ring Intercom setup unsuccessful (SKS HT4600)

Yes, I do have a BUS-based system that dictates that someone has to ring the doorbell before one can trigger the buzzer. But still, there might be cases where someone rings the bell, I go to the Ring App and would just like to press that button, without having to go to the call screen. From what I read above, this is supposedly something the Ring Support can enable, I’ll see if that’s true.

With call screen you can still do a direct unlock without having to pick up. I think even the notification has an unlock button showing up which you can directly use? Or is that not the case on your app?

Hey Neighbors. For support regarding your Ring Intercom, we have this Help Center article here. If you have any question, feel free to reach out via Email or Phone. Thanks, Neighbors!

Hello Guys,

i also have the SKS 4600/1 (which this thread is actually about, right?! :wink: )
i connected everything and started the test. i was able to hear a sound from the intercom. but it was not able to open the door. after that i checked cables again, reseted, changed the battery and now (even i did not changed any wiring) i am not able do hear the sound anymore. it just tells me connection problem like most of you also have.
contacted the ring support, they are on it. for me it seems to be a software bug, and nothing related to the wiring as it does not even start the testing.

@smarthomer
Ring support can definitely enable the button. They asked me if my intercom can open without picking up. I confirmed & without reset only by closing the app the button was there.
Funny thing: as I have the issue that I am not hearable, a did a reset and added the device again.
Outcome: no button (again)
not hearable (still)

I am in contact with support. Still devasted.

Yes, I think that works. However, then the only way to get to the call screen is by tapping the notification.

Imagine a case where: the notification comes in late, I’m busy in one room, can hear the doorbell ringing, don’t want to walk to the handset (just to open up for the package guy who wants to put something in the building).

Then it’d be great if I could just buzz the door open or even better: reach the call screen with another type of button, not just the notification which might come in late or be overseen with iOS 16’s great notification system.

Well, what can I say. I just re-installed the Ring app (because yesterday it was missing some doorbell ring detections :frowning:, so I thought maybe that helps). After re-installing, the unlock button magically appeared!
Cool thing is, that it now also appears in the Dashboard, I can simply tap there to unlock.

I’m not sure if the Ring team did something in the background. I had raised this with them, and then even some other support representative called me about my initial issue, as he saw that some new ticket was updated. Even during our call, the original ticket was supposedly updated by engineering with some technical information. So they’re watching in the background. :sweat_smile:

Great! Now I just hope the Ring intercom doesn’t miss more doorbell rings, I’ll have to observe this a couple of days. If I just occasionally get notifications, then it’s pretty useless.

Yup, that was the initial system I used and posted about here. Although I’m currently using a HT4600/2, I’m pretty sure they’re almost identical. I bet I could plug in my v1 and it would work the same.

For this specific screen you’re seeing, I’d attempt a couple of things related to your WiFi network. Maybe try adding the Ring Intercom to a guest WiFi network instead of your main one (since you’re German and probably have a fritz!box :smiley: that shouldn’t be a problem).
For me that was, for whatever reason, the solution to get it added initially.
Of course there could be other factors, you never know.
Maybe also try:

  • re-install the Ring app
  • updating your phone’s OS
  • restarting your phone
  • ensure there’s no active VPN connection
  • ensure there are no ad-blockers active somewhere on the phone or on your network in general

I know, it sounds like the usual “have you tried turning it off and on again”, but some of these things have a technical basis that might actually help.

Hope we can get this working for you!

Hey,

and thank you for your help.
I tried all of them. I even made a new guest wifi named ring :stuck_out_tongue:
But it’s still not working. I can see on my router (asus no fritz box) that it is connected. I even can ping the ip address (which really takes long to answer - 100-300ms).
Battery is fully charged, device once more reset. One more firmware update. iOS 16.1. no vpn. For the guest wifi I just used 2.4ghz. Rebooted my phone. Reinstalled the ring app.
For me it seems to be a software bug. It tells me it’s connected, but when running the test (why to I have to run the test to use it?!?! So stupid) it tells me it’s not connected.

Can you run the test while put off the cable from the ring device? Just to be sure it’s nothing about the wiring. But actually I am pretty sure about it because of the message shown, and because it’s too fast and the message of a wrong wiring is different.

The SKS intercom system is a BUS-based system, meaning that it’s not working with simple analogue signals. Therefore, the only way for Ring Intercom to be able to detect what signal on the BUS represents someone ringing your specific doorbell button, is by conducting this test and during the process to record that specific signal to be able to detect it in the future.

So unfortunately, this step is mandatory.

I agree with you 100%, that the issue is probably not wiring-related. As I said in some of my other posts, I basically never touched the wiring after initially connecting it.
And the device was showing up in my main WiFi network from the beginning, I was able to ping it as well from the start.

So it seems like I somehow got lucky along the way. :frowning:

I wish I could help you with the “secret recipe”, but I’m afraid it might just not exist.
I can only suggest to try a full reset every now and then (I did this like 50 times).
This is not acceptable at all though, Ring needs to address this and provide a fix, whether it is for the device firmware or the Ring App - hard to tell what is causing this exactly.

ok, thank you anyway for your help. i will wait for the ring support. 3 weeks left, then i have to send it back, if it is still not working.

I’ve forwarded this thread and especially your report about the same issue to them in context of my initial support request (hinting that it might be a broader issue). Will let you know should I hear anything back from them.

Got a message from support that I know should try again and now it’s really working. I don’t know what they did. But I was able to end the test.
I am no wondering how can I just press open with the app? Am I really only able to open the door when someone is ringing?

Awesome!
So there seems to be some secret sauce they’re adding in the background. Might be the reason why it worked for me as well.

I think you got the same feeling as I did after successfully finishing the setup. Now that it’s working - the feature set is just so slim, not even the unlock button is there. :laughing:

If there is currently no such blue unlock button:


Then currently you can only unlock the door through the call screen. :frowning:
The thing with this SKS system is, that someone has to ring the doorbell anyways in order for you to be able to unlock it - or is yours configured differently?
I’m assuming that’s why Ring decided to hide that button in that case. I agree that it should still be present, because fully relying on the ring notifications & call screen is not optimal.

Some people here posted that Ring can enable this button. I called them about it, they said they couldn’t enable it (not an option on their side).
Then later, check out my previous post: Ring Intercom setup unsuccessful (SKS HT4600) - #67 by smarthomer
By re-installing the Ring app, it appeared all of a sudden - not sure if they changed something in the background again or not. Maybe just try that, and if it doesn’t work, reach out to them and also request for that button to be enabled.

Be advised again: with the SKS system, one has to ring your doorbell before you can trigger the buzzer. Even with the button present, the BUS will block the request to open the door without a preceding doorbell event.

yes thats exactly what i thougth: “WTF why is there no possibility to open the door simply with a button??? where the heck is the open door button???”
the problem is that sometimes i do not get any notification on my phone. most of the times its working, but sometimes not. thats worse. but what is even more worse is that i can not simply press this stupid open button, because there is no button! WTF??? i want to press this button whenever i want, and not when ring wants it! because there is NO good reason to disable the button, let the customer choose! -.-
next use case is when you forget t open the door within “the ring call” or you quit the call accidentally. then it would be great (or actually necessary) to have a simple open button.
i am really angry about this. furthermore there is no official api, which is really bad for a smart home gadget that you want to integrate in your smart home. with an api it would be possibile to build your own “ringt to open” feature, which is the next feature that is missing.
really bad, 3 weeks to go, then i will go back to nuki if nothing changed, even if i really love the audio feature. it would be grate to combine both. but that seems to be problematic, or at least i dont know how to wire it. do you have any experience with nuki or, even better, with nuki combining with ring?

p.s. i uninstalled the ring app and reinstalled it, but still no open button. i have written the support.
p.p.s i have seen you had(?) similiar problem with the ring detection or at least with getting notifiations. therefore you reinstalled the app. is it better now?

Yeah, I get the frustration.

Ring doesn’t seem to be the company that will offer local APIs for their products, unfortunately.
We could however see something coming in the DIY home automation space soon though to make things work with other systems. :slight_smile:

I do have a Nuki Opener as well and it is running in parallel (shouldn’t affect this device as I’ve just soldered a couple of wires to run the Opener in analogue mode - not messing with the BUS). There was a thread on the Nuki forum about it, it was hidden due to legal reasons, I can DM it to you (edit: well I can’t, doesn’t seem to be possible here…), direct link access should work.

I think I was still missing a couple of ring detections / notifications. It looks more like it’s not detecting the doorbell ring at all, because in these cases nothing show up in the event log / history…
So yeah, not optimal, because in these cases you have no way of going to the call screen to talk to whoever is ringing the doorbell, and in your case to even unlock the door.

i already have set up the nuki opener and it was working absolutely great. but it was disrupting the ring detection of ring intercom, therefore i decided for my tests to disconnect the nuki opener. actually only the yellow cable coming from the handset had to be connected again to the board ( i had to cut the connection as i had to connect the nuki opener inbetween (probably for the ring detection)). and i disconnected the mail cable from nuki opener because otherwise it wont working for me.
but still out of two ring bells today no one was detected. i just restarted the ring intercom to see if it helps… dont know yet.
i would really love to get in touch with you to share some pictures,