Ring Intercom setup unsuccessful (SKS HT4600)


I’ve already contacted the Ring Community Support and got this issue escalated to engineering. Currently awaiting a response.
I wanted to open this topic, just in case someone experiences the same issue and to create some transparency.

I’m not 100% sure how to categorize this issue, from the error described below it might be something other than a compatibility issue with my intercom. Could be a pure Ring App issue as well.

Running iOS 16.1 on an iPhone X.
My intercom system is a HT4600, the brand is SKS.
Wiring instructions displayed in the app:

  • Insert wire B-2 into port b
  • Insert wire B-1 into port a

I’ve followed through the setup instructions given by the app, up until the point where the app is asking me to do a “test” for which I have to go downstairs and ring my doorbell. The Ring Intercom device successfully switches into the “testing mode” - you can hear the click of a relay inside the device and see the green light.

The next step is to ring the doorbell and confirm this action.
However, whenever I click on the “I pressed the button” button, the app switches to an error screen as follows:

Here’s what I attempted to mitigate the issue:

  • Rebooted my router (well, I knew this wouldn’t do anything, but yeah…)
  • Updated my phone to the latest iOS version & re-installed the Ring App
    • This actually made a difference, when I tried to setup the Ring Intercom device again, it ran through a firmware update this time - not sure if that was a coincidence)
  • Ensured there is no active VPN connection on my iPhone (saw similar threads where this error screen popped up when setting up other ring devices, but does not apply in my case)
  • Restarted the Ring Intercom device (removed battery)
  • Serveral resets of the Ring Intercom device (wiped clean by pressing the button for >=10s, removed it from app)
  • Checked the wiring multiple times, everything is as it should be
  • Rang my doorbell both from the outside unit as well as the button directly in front of my apartment)
  • Attempted the test while connected to my WiFi (left the phone inside), as well as through a mobile data connection (from the error it got me thinking if that makes a difference, but it did not)

If anyone has any suggestions on what else I could try, just let me know, happy to try out things.
I’m going to keep this topic up to date with whatever information I receive from the Ring support & engineering team.



Im having a similar issue the test keeps failing and saying i have wiring issues even though i have wired it all correctly . I had the same error come up once the one with the connection i didnt see it after i believe if you restart your phone maybe that will help and leave it next to the intercom box when doing the test

Thanks for sharing! :slight_smile:
Unfortunately, for me there’s no way around the connection error, I’ve already restarted my phone several times. Even updated iOS along the way. And as mentioned, I did also try to keep it upstairs, connected to my WiFi network - to no avail. :frowning:

Your issue surely looks like something the engineering team should take a look at.
@Broshi I see that you mentioned in your topic (Ring Intercom not working), that calling the Ring support didn’t do anything for you. However, I’d like to share a different experience. First I talked to someone who seemed like a “1st level support” person to sort out the easy issues. Then they transferred me to a very competent person from Germany who assisted with further troubleshooting and then happily passed my issue on to the engineering team. Further communication was via mail, where I’ve submitted some photos of my intercom’s circuit board. Maybe you’d like to try calling them again?

Yeah just got off the phone from the first support team and he went through everything and same issue was found he’s passed it onto the engineering team waiting for the call back hopefully they can resolve it

Hey @smarthomer and @Heych - thanks for your replies! Glad to see I’m not alone with those issues :slight_smile:

I will try leaving the phone upstairs once I’m back from work and report back, I wasn’t offered e-mail communication or help from the engineering team by the phone support so I will try that again as well, thanks for the hint!

If any of you manage to get it to work I would appreciate it if you could let me/us know, and perhaps even share a solution!

I fitted my intercom a few days ago. Using set of wiring number 3 the set up and test worked ok.
My major issue is the lack of the functionality I assumed it had.
I ran the compatibility test, all came back fine. I have a Videx 3171 intercom unit (set wires b)
What I cannot get working is the remote unlock function. I cannot unlock the door unless a call is initiated from the outside door intercom.
Yes if I’m outside my door. I can press my house number, a call will be forwarded to my mobile ring app (where ever I maybe) and I can answer and unlock the door.
But I cannot directly open the door, this means I cannot share access to a family member so they can unlock the door themselves.
This is a major function. I called support who rather unhealthily informed me that my Videx intercom does not support this.
I’d be interested to hear what function the intercom must have to support this. I was to replace it there would be no way in knowing if it would still work. Ring need to be more upfront about their compatibility test. One would assume a pass would mean all functionality would work, not just some.
This was what I was told on first tier support, it might be worth investigating further.
I am really disappointed though.


No unlock door button

@Davidjtaylor1975 maybe there’s some validity to that, if the handset has to be off-hook in order to unlock?

This is what I see with my intercom system (Came BPT System 200 4-wire intercom, with AGT A200 handset):

Yes I believe this is what should be seen. Can I clarify though, if I or a family member was to unlock the door remotely, the apartment handset would be in place and not off the hook. I don’t understand? Isn’t that the point of remote unlock. Similarly with the Amazon auto verify, the hand set again would be in place.


Yes of course. However with my particular handset (from a different intercom system to yours) there is a link/jumper on the circuit board inside the handset (SW11 in the following image) which, if cut (ie. disconnected) would require the handset to be off-hook (ie. raised) before the AUX button (door unlock) could be activated. By default the link is in place, so the door can be unlocked without lifting the handset (and Ring Intercom works with my handset like this just fine - I’ve no idea what it would do if the link had been cut, I’d be kinda surprised that it could even tell and the door simply wouldn’t unlock “remotely” because the handset is not lifted).

Maybe this is the issue you are facing with your handset? Easy to verify of course - does the physical door unlock button on your handset work without raising the handset?

Interesting I don’t really know tbh. But I will test that, if indeed it does unlock, does that mean in I might be able to get it working?
Great if so, I’ve provided an image of my intercom (inside) see if that helps.

I do think that the blanket test provided by Ring is a bit poor. It came back and said my handset was compatible (but didn’t say would be reduced functionality)
To me the remote unlock is a major feature.

Anyway thanks for that tip, I will try that.



Does the unlock button work without pressing the button to your flat on the main entrance ?

For example for me to enter i need to ring my buzzer on the main entrance and then when i press unlock it will unlock the door but if i press the unlock button when the button isn’t pressed at the door it wont unlock the door. So does your do that without having to buzz in first. Please let me know and if any solutions thank you

I have a different handset/system to your but mine also relies on using the same harness and just B1 and B2 and I am having exactly the same issue.
Unfortunately I’m not going to have a chance to investigate/phone the help line until next weekend so I’m hoping that Ring come up with a solution by then.

I think it will be quite a common issue.y gripe is that I was assured compatibility with my system Videx 3171. I didn’t expect only some features to work. I do have the option to return it. But I got the whole set up at a very good introductory price. I think it’s worth pursuing with.
I’m hoping someone from here might have a work around. The issue seems to be whether I can open the door without lifting the handset (I’ll try when my friend comes around)
I’m hopefully it can be resolved by jumpers or adjusting something and is straightforward. If not I still have the answer anywhere facility.
I’m wondering too though if the remote feature does not work, I assume the answer by Alexa or Amazon delivery don’t work either. I will rest this too.
A good idea, but retrospective fitting is going to be the flaw I think. We need a more comprehensive compatibility check.


I also have a Videx 3171, slightly different board but mainly the same. No issue setting up other than the outside entry panel not getting voice just a high pitch hum.

I also cannot remote unlock unless some one calls the apartment but equally I cannot talk to them as they only hear this hum. Does anyone have any idea how to cure what appears to be audio feedback or similar

Glad to hear I’m not alone with the original issue I posted about (if I understood correctly).
I’ll definitely keep this thread up to date about the connection issue, whether I figure something out or the Ring team.

Not sure why this thread is being hijacked for other unrelated issues.
This is not a generic “Ring Intercom” issue thread. :smiley:
It took me a while to figure out how to create a new topic here as well, but it’s definitely possible and I’d advise to do so, just to keep things tidy and organized. I’m sure people coming here from Google searches will appreciate that as well.

@Davidjtaylor1975 This site may be useful to you (and others) - it includes basic details of the Videx 3171 Digital, and many other handsets which may help make sense of how things are being wired up (particularly if you don’t have a manual).

The Videx looks like it is a 2-wire system, which are often based on a “bus” system, and your handset PCB appears to be a LOT more complicated than my 4-wire handset (BPT AGT A200K which is equivalent to the BPT AGATA C 200 on the site - the PCB appears to be populated with just passives, no ICs in sight, I guess they’ve optimised the snot out of these old analogue systems over the years!)

Hopefully these teething issues with 2-wire/bus systems can be resolved with updated firmware.

I am also missing „the button“ to open remotely, BUT I can do it via Alexa App by speaking (No one has to ring upfront). So I am not sure, if this rather a bug or they even haven‘t programmed such a button.
After my installation ( which was also aborted several times) I am totally disappointed. No remote open (except Alexa) no Geofence, I am also missing the promised Amazon delivery possibility…

@AdminMbl maybe remove device and set up again once i did that a firmware update came up and everything worked fine after that

Removing the device and re-adding it forced a firmware update (it updates when you get back to the test step), unfortunately it is still the same for me after the update.
System: Comelit 2408W/A
Wiring: B - B1 to L, B2 to L
Error: ”Something went wrong” when testing the buzzer

Do you have a remote „open Button“?