Ring Indoor Cams Won't Connect

I just changed out my router and network password. I was able to easily update most of the security system, as well as my hardwired Ring doorbell and my two wireless stick up cams, but the indoor cams will not connect to the network. They connect to the Ring system, but say that the wireless network is out of range. It’s ridiculous because the two stick up cams are farther away from the router than the two indoor cams, and they had no problem. I tried deleting one of the indoor cams and adding it back, but I get the same error. I also took that same camera into the same room as the router to plug it in, and that didn’t work either. Any ideas for something else to try? Since they don’t have batteries, I can’t pull the batteries to reset them.

Hi @RickaG. Those were excellent troubleshooting steps to try. You can also try resetting the Cameras and then connecting them to your new network. To reset the Cameras, press and hold the setup button for 20–25 seconds. If this step does not work, reach out to our support team for further assistance