Ring doorbell Solar charger from working to "not connected" in 1 week

I’ve seen this a lot on the AMAZON reviews before I purchased but I figured I’d roll the dice. The solar panel connected and worked for about a week and now the status has changed in the app to “not connected” even though nothing has changed physically with the set up.

This seems to be a common problem. Solution?

Hi @Reality. I’d suggest disconnected the Solar Charger, ensuring there are no dirt or debris on the Solar Charger itself or the connections. Once that’s checked, reset the Doorbell by holding down the setup button for at least 20 seconds. You’ll then need to set it back up in the Ring App with the steps under Set Up a Device. From there, you’ll want to reconnect the Solar Charger and ensure it is receiving at least 4-6 hours of direct sunlight per day in order for it to provide a trickle charge.

If the Solar Charger still appears to not be working after trying these steps, please give our support team a call at one of the numbers available here. They’ll be able to take a much closer look at this for you and offer more advanced troubleshooting support. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. :slight_smile:

Have the same issue. Got the solar panel, it started saying “not connected.” Why should I have to undo the front plate, check connections and reset every time this happens? Isn’t there a better solution to this? This is ridiculous.

3 Likes

@nash123456 wrote:
Have the same issue. Got the solar panel, it started saying “not connected.” Why should I have to undo the front plate, check connections and reset every time this happens? Isn’t there a better solution to this? This is ridiculous.

Hello @nash123456 ,

You didn’t specify which Ring Doorbell model your have. I don’t know if you own a Ring Video Doorbell 3 or 3 Plus, but if that is the case, there is a little known improvement that could give you the illusion that your doorbell is not charging properly.

The trickle charge the Ring Video Doorbell 3 gets from being hardwired or the solar charger is solely used to charge the battery and in order to maximize the lifetime of the battery, the “Ring Video Doorbell 3” and “3 Plus” now waits for the battery to hit below 90% before using the wired power to recharge the battery. Since I don’t own a “Ring Video Doorbell 3” or a Solar Charger/Panel, I’m kind of just guessing here about this, but it could be a potential explaination.

https://support.ring.com/hc/en-us/articles/360038856311-Charging-the-Battery-for-Your-Ring-Video-Doorbell-3

Once the battery level falls below 90%, it should start charging and display a “lightening bolt” symbol in the center of the Battery Icon on the Device page to indicate that it is charging. Even while the solar panel is then charging, it is very possible for the battery level to continue to fall until the power demand decreases and the solar can slowly catch up in bright sunlight. If you allow the battery to go below 90% and does not indicate that it has started charging again, then it could be something else, and you should call Ring Support for additional help at:

https://support.ring.com/hc/en-us/articles/360036196372-Get-in-Touch

Unfortunately, due to the Covid-19, their available hours have been changed also:

https://support.ring.com/hc/en-us/articles/360041597471-Ring-s-Response-to-COVID-19

I hope you find this information helpful. :slight_smile:

1 Like

Mine has been working fine previously, but in the last couple of weeks just displays “not connected” all the time.
Have taken it off and rescured the connections, but still the same.
Seems to be an issue for many having googled it.

2 Likes

same here, have a gen 1, and dont think it ever worked. has full view of the sun. also have a ring solar cam and has no issues. about to call support but figured I would check with the community. does anyone here have a fully working solar charger for the doorbell?

I’m having the same issue. My video doorbell3 worked for couple days then getting not connected. Did the recommended troubleshooting disconnected from solar panel reconnected and reinstalled the whole device…Same thing. Support were very helpful I must say.

1 Like

I’m having the same issue as well. It started to say ‘Not connected’. I checked last time and it said it is connected but today, it says ‘not connected’ again. I have not touched the door bell and nothing has changed physically. Considering that others are also seeing this same issue, I think this is something Ring need to address. This is with the Ring doorbell 3 plus which is just a couple of months old.

We in stalled our new doorbell yesterday (gen 3 pro) with the solar power panel however in the app the panel is showing not connected
We have checked the connections and they are all fine

We have the video doorbell 2. Just got a solar charger and installed it yesterday. The app said it was connected. Took the battery out to charge it last night as it was low and still going lower, thinking that having a full battery would be better with the solar charger trickle charging it. However, since putting the battery back in the app says the solar charger is not connected. I’ve tried re-setting the bell and have reconnected it. The app still says not connected. What’s going on?

Note: Due to the firmware upgrade,please install it when the battery power is lower than 80%, otherwise the APP cannot recognize the solar charger. You will find that the APP does not have a rechargeable icon, don’t worry, check the battery level after 1 hour, you will find that the battery level has increased.After the battery is charged to 100%, it will stop charging. When the battery is below 80% next time, the solar charger will quickly and automatically resume charging. GOOD LUCK!