Ring Doorbell Pro stuck in firmware update

I’ve had my Ring DoorBell Pro installed now for 5 years now and it’s been pretty faultless in that time. It’s hardwired with the Ring transformer & bypass kit, and its been great.

This weekend, the doorbell stopped recording video around 3am on saturday - seemingly to install a firmware update - and since then, has not reconnected to my wifi.

The lights on the doorbell show it’s in firmware update mode (pulsing white light), and every 5-10 minutes or so it will restart itself, but always goes back to the firmware update mode setup. It will not go into setup mode.

Things I have tried include:

Hard reset (hold down until you get the flashing lights, wait a bit longer and release)
Setup mode
new setup on the app, new install of app, removing from account & re-adding etc
network reset & router reboot
Completely turning off the power to my house, waiting 2 min and then booting it up again.
disconnecting the doorbell physically and re-installing to the wall

Whatever i do, it refuses to enter setup mode and stays in firmware update mode.

I have tried ring support and currently waiting for a supervisor, but after going through the above with them, all they want to do is offer me a meaningless 30% discount off a new device…for a software problem that THEY caused.

Any suggestions where to go from here/ I’m getting ready to submit a small claims court case against them if they don’t help further - this is clearly not a hardware fault or a warranty issue - its fairly obvious that it tried to update its firmware and has gotten stuck. This is not a hardware issue and is totally nonsensical for them to suggest it is!

I will gladly take them to court over this if its needed to prove the point if nothing else - companies cannot remotely brick our devices and then expect us to pay for a new one, its a little ridiculous :slight_smile:

Id rather fix this one though if at all possible, so any suggestions are greatly appreciated! :slight_smile:

So here is a happy update!

The supervisor called me back and agreed this was ring’s issue, and has processed a replacement :slight_smile:
So for everyone else with the same issue - persevere and you should get a replacement!

1 Like

Hi @Spud211. I’m glad to hear our support team and the supervisor was able to help resolve this with a replacement! Feel free to mark your last response as a solution if you’d like by checking the Solution box with a checkmark. If you have any further questions or concerns once you receive your replacement, definitely follow up with our support team so they can make sure it’s taken care of. :slight_smile: