Ring doorbell pro keeps entering setup mode

I had a ring doorbell pro installed yesterday and it keeps entering setup mode after working for 5 minutes. Has anyone seen this before? It’s not clear if it’s the electrics that are the problem or the unit itself.

1 Like

Hey @Stevef90. When you go into the Device Health section of the Ring app, does it say anything about there being poor power or the device being disconnected? If there is an indication of this being a poor concern, please check out our Help Center Article here for more information on how to fix this. In the event this is not the case, please ensure you have the Pro Power Kit installed as well, as this may be causing the device to lose power too. Let me know what you find out! :slight_smile:

In the event that you haven’t been able to even successfully set this up in the Ring app, please read our response to COVID-19 here to see how to contact support. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times.

I have exactly the same thing. Checked the device health and power is good and wifi is good. Even tried a different wifi access point and placed it closer. Tried 2g and 5g, but everytime after between 5 and 15 minutes the doorbell reboots and goes into setup mode.

Hi @Kryton77! When your Doorbell Pro re-enters setup mode is there an audible indicator stating “your device is in setup mode”, coming from the Pro? Keep in mind, the setup button is on the side of the Doorbell Pro, and if it is mounted close to a frame or wall it my be compressed, thus triggering setup mode.

Although power looked good in your device health, the reading wouldn’t necessarily pick up certain resistance or a short in wiring. It’s always a good step to check wiring to ensure wires are tightly secured to terminals and the wiring is not too thin. Checking the above variables should help resolve this. Feel free to let us know how this goes! :slight_smile:

Mines been doing exactly the same thing. Turned it off at fuse box, moved router, moved it back, run speed checks, all good and I’m just getting so annoyed with it now

The doorbell isn’t against a wall or frame so button on the side is safe. I’m using a ring plug-in transformer as I don’t have an existing doorbell system. I have tried it again today and its still doing the same.

One thing I have noticed, is that the instructions state to change the power setting to “none” as it’s not on an existing doorbell system. But the options for power are not showing anywhere in the app, and does not give an option during the setup to select which power type is in use.

If there is not an audible announcement that “your Ring device is in setup mode”, it is possible that your Video Doorbell Pro is actually trying to reconnect to network, rather than entering setup mode. I recommend connecting to the 2.4 Ghz network channel frequency and checking your Device Health RSSI to see if there is any network interference.

In regards to the power settings, this option can be found when visiting the Doorbell device page in the Ring app > select Device Settings > select Chime type > choose option that best fits. The “none” option should only be chosen in there is no mechanical or digital chime kit wired in.

If this concern persists despite trying the steps above, it may require some in depth troubleshooting. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Feel free to let us know how this goes! :slight_smile:

Yes, it does the audible announcement that “your Ring device is in setup mode”. Everytime, that is why I said it is entering setup mode

I checked the chime setting, it was already set to none.

Thanks for your help.
The doorbell is packed back into its box and is being returned.

Exact same issue for me a couple of days ago. Installed new pro doorbell using the ring plugin transformer. Setup initiated and completed… a few minutes of video then a message that the software was being updated… on completion it went back into setup mode. Looped through this a few times trying a different router. In the end called ring support and they sent a replacement new doorbell. That arrived yesterday and is now installed and working although it did seem to struggle for a while with the voltage changing but stable now.

1 Like

I have same issue on my brand new Ring Doorbell Pro. I’ve tried seveal things like changing wifi or factory reset etc… it works first several minutes like device health looks, then suddenly disconnected from wifi and device becomes setup mode which there an audible indicator stating “your device is in setup mode”. i am going to call support to request replacement and hope it works

I updated existing transformer to 30VA one (see amazon link)


also updated mechanical doorbell to the one in the ring compatible list (I bought Hamptom Bay’s one)


This is because to prove nothing wrong my configuration or wiring, but it resulted same, the device went to the offline.

Today, finally, I was able to speak to the tech support guy, and accoring to him my Ring doorbell had failed (actually rjected) to update the new firmware. And then it went back to the setup mode after the certain amount of time. I don’t know what actually wrong in my end, but I strongly feel that there’s a problem in the device itself. I will keep trying to discuss with them.

1 Like


I tried more than 30 times, and finally made it work!!! It was pretty simple.

  1. Press the ring button 20+ secs to make it setup mode.
  2. From Ring app, setup the device with wifi SSID and password. The device work for a while, and it seems that the device attempts to update its firmware.
  • If you just wait, then the device comes back to the setup mode in about 5 min.
  • However, during its online (first 5 min), enable “Motion snooze” for 2 hours from the app, then the device seemed successfuly updating its firmware. Yay!!!
  1. It works my mecanical chime. also Alexa integration works well.

I tried this step only once, so I am not sure it works in everyone’s case. Please try and if it works, report here. Ring tech said they are continuously monitoring this forum.

So far, the device still works more than 1+ day after the setup.

1 Like

tried this for mine and it still goes into setup mode after about 5 minutes

mine also does this! ive tried everything!

I just bought mine, set it up and ran into the same issue! Been messing with it for 4 hours. I’m done.

Well everyone - you might all be trying but I think I hold the record!

My Pro doorbell was installed in February 2020 and it worked absolutely fine for around 6 months. I added a driveway camera to the system and that was fine too. Then, 22nd July the doorbell stopped working. It has a plug in chime that came with it and it is plugged in literally 18 inches away from the door, there is nothing from an old doorbell in the system, all new provided by Ring and the sparks says he followed the instructions to the letter.

The call centre at Ring provides me with diffcult to understand people who try and say that we installed it incorrectly. I hired a professional electrician and had it wired into my consumer unit so the Ring transformer actually takes up the last 2 spare “ways” in that. I fail to understand why it suddenly doesn’t work and only yesterday spent another 30 minutes on the phone trying to convince the support member that the bell needs replacing.

I cannot press the setup button on the side of the bell and get any response, no matter the length of time pressed.

I was told in July that I was missing a Ring Power Pack - a really thin bit of plastic with 2 wires that apparantly needs to be placed into the consumer unit, although where it would be so the cover can be fitted is extremely difficult to understand. They didn’t send me one in July and they say they are now sending me one but we will see. I asked for a replacement and the chap simply said I should have returned it within 30 days.

Well Ring. I am the sort of person who doesn’t take crap lying down and I will go to the County Court if I need to, in order to get a working bell or my money back. I have paid for the web recording annual subscription and currently have been unable to use that effectively for nearly 2 months. I expect Ring will require me to fit this device but I am not sure that will be safe and it will cost extra if I call back the electrician.

I am giving this 7 days to get resolved, then I am filling in the court forms.

1 Like

I was a person who wrote [RESOLVED]. It had worked well for about a month, in motion sensing, capturing video, also live video. I really enjoyed with Ring device in the month.

However it stopped working since a couple of days ago (it seemed that the timing of firmware update), and got into same situation again. This time, disabling motion sensing or snooze didn’t effect at all. I’ve heard “Rome wasn’t built in a day” about 50 times (means I’ve tried various things :wink: as much as I can). My Rome won’t be built forever. The wifi strength is excellent (RSSI -35), and voltage is 4048mv which is Good, also I’ve replaced the transfomer with the recommended version (16v 30va) since since Aug 22, and also replaced mechanical doorbell with the compatible one.

From my observation, it seems that the problem is related to the frimware update during setup mode. As everybody mentioned, it works for first 5 min after setup. Right before crashing, LED flases a couple of times (White solid ring), then it comes back to setup mode with the voice announce.

I looked around a lot of forums, facebook pages, reddit posts, and found that a lot of people struggled with the similar problem. As a software engineer, I say this was caused by a problem in quality assuarance in Ring company. They should test it the new firmware with ALL possible hardware versions before releasing new firmware.

Hope the new firmware released very soon that cures my device problem.

After my previous comment, I tried various thing another 30 times, but never solve. The symptom was simple. Setup succeeded once. During working time, the ring button works and able to do video / voice communication, but after several minutes, white LED flash a couple times (the sign of firmware update) and then it returns to setup mode (with voice announce). Weird that it worked perfectly for a month, thus I suspect that this is firemware issue. Contacting support team is really time consuming but I will talk to them again to request replacement. I would like to hear from others how you solved the issue.

Add mine to the list too - 7 hours in and I’m giving up- adding together all of the time everyone has spent on this I think finding a permanent solution is unlikely.

Exactly the same issues, exactly the same outcome. No one has posted a solution so its back in its box tomorrow and returned.

I have just had my firmware updated by the people at ring after spending hours trying to sort it myself, had to send them a picture of the way it was wired before they would do anything, which I did and he was happy with it. Then it was done over the phone, had to give them access to Amazon account so they could do it and fingers crossed it seems to be working.