Ring doorbell not working at all

My ring doorbell is not working. The battery is fully charged but there is no lights or anything on the actual doorbell. I have tried to reset it but even they is not doing anything. It’s just gone completely dead on me. No changes to Wi-Fi or anything for it to go like this


I’ve exactly the same problem
Working until last week
Full battery
Nothing won’t even reset

1 Like

Hi neighbors. If your battery powered Ring Doorbell is unresponsive, please first try fully charging the battery using the provided charging cable. Plug it into a standard power outlet for about 6-8 hours. If your Doorbell has a removable Quick Release Battery Pack, you should see an orange and green LED lit when it’s being charged, and only a green LED lit once it is done charging.

After the battery has been charged, try factory resetting your Doorbell by holding down the setup button for at least 20 seconds. Once the reset is complete, attempt to set your Doorbell back up in the Ring app using the steps under Set Up a Device. If the Doorbell is still not responsive, please follow up with our support team to take a closer look.

The battery is fully charged. I have two batteries fully charged and doesn’t matter which one I put in the doorbell has no life to it at all. There’s no spinning light and nothing happens when you press the reset button.

A post was split to a new topic: Can’t connect to Doorbell

@SaraJFT97 Since your Doorbell is unresponsive, you would need to reach out to our support team for further assistance. They can ensure all applicable troubleshooting has been done, then determine the best solution based on your device’s warranty.

Mine too :woman_shrugging:t2:. I ve had nothing but trouble with this doorbell and its account. But yet my first doorbell that is just 6 months older is running perfectly :hot_face::hot_face:

Mines just gone……absolutely dead,charged battery,done reset,still dead….:face_with_symbols_over_mouth:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.