Ring doorbell not discoverable by Alexa

Just bought a new Ring Doorbell 2nd Generation. All setup on my phone app ok. Went to add it to Alexa - added skill, enabled and linked to account ok, but when I went to discover devices, nothing found. Tried several times via app and asking Alexa, nothing.

Anyone any ideas?



Hi @mICROSCAN5EP. If you’re having a difficult time connecting your Ring Doorbell to your Alexa device, it might be due to your wifi signal. In the Ring app, what is the RSSI for your doorbell? This can be found under- Menu > Devices > (Ring Device) > Device Health. If the signal is too weak, it might have a hard time detecting it. Also, prior to discovering the device, make sure your Doorbell is online by pulling up a Live View. Let me know if this helps!

Thanks for the reply, unfortunately still no joy.

The RSSI is -52 which is pretty reasonable. Tried bringing up live view then running the Alexa discovery mode, but it didn’t find it. Both Alexa and the Ring device are on the same layer 2 network, both getting their IP from the same DHCP server and I can ping both devices from my laptop (also on the same L2 network).

Alexa has found other iot devices without issue (several lights and eWelink devices).

Open to suggestions…

Hi @mICROSCAN5EP. If your Ring Camera has a good RSSI, and you’re able to pull up a Live View, then the issue may be with your Alexa device. I would suggest contacting Amazon support to troubleshoot and see if they can help discover your Ring Devices. Please come back and let us know how they were able to help!