Ring doorbell not charging

I have had this doorbell less than a year and it doesn’t seem to be holding charge or even charging up at all. I’ve tried different cables. What can I do?

Hi @rycamshaw. What specific Doorbell model do you have?

My ring doorbell has stopped holding any charge. It is completely dead.

when I plug it in to charge after about 10 mins the light will start flashing to show it is charging. I left it on charge all day and over night (so had plenty of time) the ring app showed 100%. As soon as I unplug from the charging cable the device is completely dead.

I would like to order a replacement as this items internal battery is not working. I have ring protect plus but cannot get through to customer services having tried and been on hold for over 6 times. I am calling from a mobile so worrying about phone costs. Also the online chat just tells me to contact customer support.

Please help !!!

Hi @user80696. Feel free to send us a message on Facebook or Twitter. If you don’t have an account on either platform, it only takes a few minutes and can be deleted when you are done.