Ring doorbell not charging and not connected to Wifi

I’ve been charging my Ring Doorbell for almost 4 hours and the device health info have not changed status. I tried to tested the device by trying a live view and just keeps buffering. I figured it might be the internet connection. I’ve tested the Wifi and it the speeds are 40 MB download and 17 upload which is sufficient for the Ring. My Ring doesn’t seem to be charging or connected to Wifi but I’ve tried to plug in again to recharge and also tried to reconnect to the Wifi and it does not seem to be working. Thank you for your help.

Hey @JediVen. You normally have to charge the Ring Video Doorbell for about 8 hours for a fully charged internal battery. In addition, I recommend not using the device when it is charging, as it may affect the charging time needed. Once the device is fully charged, try reconnecting to wifi through the Device Health page. If this fails, please remove the device from your account, reset it by pressing and holding the setup button for 30 seconds and then re-setting up the device. In the event that it may still not set up properly, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.