Ring doorbell generation 2. New and not holding charge

We recently got a new ring doorbell generation 2. When setting it up we’ve had it on charge for the past weekend. It will only flash the blue light and then doesnt procede to charge. Ive set it up whilst its been plugged in but it still says its on 5%. We’ve changed the usb plug and the socket but nothing seems to work.

Hi @Lfell140100. Try performing a reset on the device by pressing and holding the orange setup button for 20 seconds, then releasing it. Once that is complete, reconnect it to WiFi. Let me know if this helps.

I’m just recently experiencing the exact same problem with my Gen2 doorbell. I got an alert to warn me that my battery charge was low. No problem just unfix from mounting and re-charge overnight as I’ve done many times before without issue. However on this occasion it hasn’t charged but the app says it’s 100%. All I’m getting is a blinking solid blue light that stops blinking for approx 30 seconds and starts blinking again. Pressing the orange button on the back does nothing no matter how long I hold it for. I’ve tried uninstalling and reinstalling but still nothing. These are very expensive pieces of kit to provide you with security and you don’t expect them to fail after 2 years. Anyone out there with an answer will be gratefully appreciated?

1 Like

I’m having the same issues a brand new ring camera. It won’t charge up, I’ve tried re booting the device etc and it still isn’t working.

Hi neighbors. If you have tried a factory reset and have verified that there is power on the wires connected to the Doorbell but are still having the same concern, reach out to our support team for further assistance. Give our support team a call at one of the numbers available here.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.