Ring Doorbell "{devicename} isn't responding" in Echo Show

Sorry to hear about this, neighbors! Your Alexa enabled devices, Ring skills, and routines should be working as intended. As mentioned prior in this thread, the best first step is to check network connection for both Ring and Alexa devices, for an optimal experience. Next, try removing and re-adding these skills and routines, as well as remove and reinstall the apps on your mobile device. Checking for an update may help as well.

Some neighbors have shared success with power cycling their network, if you notice both Alexa and Ring devices are not connecting as intended. If this concern persists, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

I have the same issue between my echo show 5 and my doorbell and spotlight cams. It’s a constant issue. Cameras show fine on other WiFi devices . Removing the Alexa skill, restarting devices, and resetting my network have had no effect. Seems like these are the only suggestions for fixing this from ring support. Is anyone going to take a serious look at this?

I’m so glad I found this thread! I’m having the exact same issues with my brand new Echo Show 5 and my 1st gen Ring video doorbell. When I say: “Alexa, show my front door”, it says “Front Door isn’t responding” and it goes to “Waiting for ring.com” screen for like a second. Already did everything that was recommended, and nothing works. But if I’m persistent and ask “Alexa, show the front door” several times, it works on one of the attempts. Sometimes on the 3rd time, sometimes on the 4th time. Once I got lucky and it worked on the 2nd attempt! This is extremely frustrating because I only bought this to connect with the Ring! Piece of crap. Any fix??

Yall have the same lousy replies like this isnt a RING issue. Clearly this isnt just randomly happening to people in random places that have spent hundreds of dollars with your company. Yall need to fix this. I didnt buy these cameras for 35 secs of surveillance then 35 seconds of buffering and cutting out

I assume this has never been resolved?

I purchased a ring door bell camera and an echo show 8 and have the same issues as others - connects when it feels like it. It does however work correctly through the phone app

I have the same issue with mine. So frustrating! It takes far to long for my Echo Show 5 to connect. Too many times a person has been at the front door before the Show even connects.

One thing I found a bit odd…just today I received a survey from Amazon inquiring if I would be disappointed if Alexa and Ring parted ways or what they could to improve. Maybe they ARE working on it???

Ring are pretty quiet on this thread, so clearly Ring do not “support” seeing camera’s in Alexa Show!

I have the same problem “Waiting on Ring.com…”.

  • i disconnected and reconnected the skill… no fix
  • The ring app works fine on computers and mobile phones, so it not ignore the “solved” above.

Hi there, neighbors! If you have not already tried, please disabled and re-enable the Alexa skill. The next best step, while still in the Alexa app, select your Ring device and toggle the Announcement toggle off then back on. This should update the name displayed. Please let us know if this worked! :slight_smile:

I deleted Ring as a skill and re-discovered the device and added it back. I also toggled between enabled / disabled several times. I also toggled back-and-forth several times on the announcement selection. None of this allows me to view my ring doorbell from my Alexa Show. Sooooooo frustrating. Please resolve!!

Problem:

I was getting the “already showing to other devices, can’t add to conversations” (something like that) when asking Alexa, “show the front door” for the Ring Doorbell. It wouldn’t show the camera feed on Echo, only on a tablet/phone. Spent hours restarting, reconnecting Doorbell, then factory resetting Echo device, disabling/enabling skills, etc. and none of that worked.

FIXED:

Thanks to the tip from this poster hours ago:

Go into the Alexa app (not the Ring app) > Devices > All devices > select your camera > and then in the top right corner there’s a trash icon (which is way too easy to not see considering other Amazon interfaces show the remove option as text). Trash/delete that device. Then click + to add a new device > Camera > Ring > it will scan 45 seconds and hopefully find your device and proceed to add it.

That fixed it for a short while. However, the problem came back suddenly after making changes to device settings, so I did the process again and so far it works. It could easily flip back again to not connecting, but at least the fix works temporarily. Something is obviously buggy with Amazon’s Echo or Ring software for this “skill” and needs to be addressed. Good luck!

I’ve the same issue. “Alexa, show front door.” I hear the sound from my camera, but the camera does not display. Screen says “Waiting for Ring.com”. After approx. 20 seconds, Alexa says “Hmmm, the camera isn’t responding.” and closes the connection.

I can see my front door camera in the Ring App on my cellphone while connected to the same wifi access point and SSID with almost no hesitation.

I will try the things I see noted here.

Thanks.

I disabled the Ring Skill and re-enabled it and it did not solve the issue.
I can view my camera in the Alexa app on my cellphone and in the Ring App on my cellphone while connected to the same access point as my Echo Show 10 G3. Why can my Echo Show G3 not display video??

Hi there, @mijanko! Great work on covering those steps. As video is connecting and working when manually viewing through the Ring app, this is a great sign that your network is delivering video and your Video Doorbell is working as intended. I recommend moving your Echo Show closer to the access point to avoid any interferences. Please also ensure this Echo Show is connected to your 2.4 Ghz wifi, rather than 5 ghz. I hope this helps! :slight_smile: