Ring Doorbell "{devicename} isn't responding" in Echo Show

You couldn’t tell that from the latency in Orlando that I don’t see at all on friends’ setups in Snohomish.

Does anyone know how to fix this then?
I’ve had it working for so long and few days ago I keep getting the “camera is not responding”.
I’ve tried disabling and enabling the skill but it still doesn’t work.

Any ideas please???

Here’s the working solution for me, YMMV.

I have four Ring cameras which worked perfectly with my three Echo Shows and the iOS Alexa app for about six months. A few weeks ago, whenever the front yard camera would detect motion, the nearest Echo Show would announce it, spin its wheels for about 20 seconds, and then say “hmm… the front yard camera isn’t responding.”

My other three Ring cameras still worked fine with my Echo Shows. Also, I could still connect to the front yard camera using the Ring iOS app. The Alexa iOS app would not connect to the front yard camera, but still connected properly to my other three Ring cameras.

I went painstakingly through this thread and tried literally every suggestion, to no avail. I then wanted to reply to this thread, so I had to register my Ring account with the Ring website, even though I was already registered with the Ring iOS app. That’s when I figured it out!

On the Ring website (not the Ring iOS app!) I clicked on my front yard camera. The website told me that this camera uses an outdated HVEC video format, and asked if I wanted to switch it to Legacy Video Mode. I accepted, and like magic, the camera now works on all devices and apps.

My theory is that Amazon pushed out some Alexa software update which dropped support for older video formats, and that one of my four cameras was of an older manufacture date. The older cameras require being switched to legacy mode to work properly with the updated Alexa software. The capacity to update the camera video mode seems to only be available through the Ring website.

Not the best user experience, but all’s well that ends well. I hope this helps some of you.


Just to let you know the reply from Dark_Illuminations worked for me, I accepted the switch to Legacy Mode from the website & not the app & BOOM! It worked straight away.
Thanks Dark_Illuminations, it was doing my head in.

1 Like


That is the solution! Log into Rings website and click on the camera that doesn’t load up. It asks to switch to Legacy Mode and once you do the problem resolves.

Clearly Ring themselves didn’t attempt to trouble shoot this :roll_eyes: Turns out to be an easy fix.

Thank you :pray: worked for me had to wait a couple of minutes but worked in legacy mode as stated, thank you for taking the time to investigate.

1 Like

That is the solution! Log into Rings website and click on the camera that doesn’t load up. It asks to switch to Legacy Mode and once you do the problem resolves. THIS WORKS THANKS.

1 Like

I joined up just to thank you for your help! It worked for me. 90mins it took me to sort this. It’s a pitty it took a member to sort this out for others, and not ring!!!

1 Like

You absolute star! Thank you !

1 Like

Thanks @Dark_Illuminations that worked for me too.

For others, you don’t have to only do this on the website.

Open the Ring app on your device
Select the cog icon on the camera window/panel that is playing up
Select the 9th tile “Device Settings”
Select the top option “Video Settings”
Select the bottom option “Legacy Video Mode”
Toggle the option “Legacy Video Mode” to ENABLED

The above options selected on an android app - iOS may be different.

I’m interested to know who has caused it - is it Ring rolling out a new Codec that Alexa show devices and indeed some web browsers cannot understand?
Seems to be the most likely as with this setting we are effectively ‘downgrading’ the camera to maintain support for Alexa and those older browsers…

1 Like

Wow this legacy mode fix works for me to
I have a Ring gen 2 doorbell that was fine and suddenly video wouldn’t work on my EchoShow5 and the Alexa app (but fine in the Ring app). Turned on legacy mode and hey presto perfect again. This a massive balls up by Amazon. They’ve changed the format and not considered the implications on older devices they still sell! And to make matters worse they haven’t told their customer service team how to fix it. The fact it’s taken users to find a fix to their own product they broke is pretty shocking.

I have this issue and it’s pissing me off please help me fix it why did I purchase two Alexa’s and a ring device at full price and it’s still not working I even got a gigabit connection from Verizon Even the Alexa app on my TV won’t show the picture and picture when it usually does it keeps saying waiting for a ring.com on all of my devices

The legacy mode solution worked. I tried all the other troubleshooting solutions that ring suggested and nothing.

Thanks Dark_Illuminations for the fix!!! :slight_smile:


1 Like

The new Codec - HEVC (H.265) is ** capable of compressing video with a double data compression ratio** while only requiring half the bitrate to maintain the same video quality and halving storage compared to H. 264.

So it is not surprising that Ring implemented the new codec in their cameras. I don’t think they ‘Suck’ for doing that. Where they do suck is not timing the update to coincide with adding support for the new Codec on Amazon’s echo devices.

Furthermore, knowing that they did not coordinate, they should have issued a simple support page for this issue or even emailed their database of customers with the workaround discussed above.

Brilliant, this was doing my head in!

Thank you [Dark_Illuminations]

What it is is rank incompetence. To bring out a new codec which is not compatible with older devices and then their support staff to give everyone the standard help process when this will never work as the codec is incompatible…? If that’s not rank incompetence I don’t know what is!

I found the way to make it work. Open ring app. Got to the front door camera(doorbell). Go to settings then device settings. Next go to video settings then go to legacy video mode and turn it on. Tell alexa to open front door and it should work.

1 Like

@Dusser1 that won’t work for the iOS app.

@Silverfox.Mike interesting… this option is not in the iOS version of the app.

In January 2023, Android accounted for about 45 percent of the mobile OS market, while iOS accounted for around 55 percent. However, in first world countries, people who are using Ring cameras, I expect that there are much more than 55 percent using iOS.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.