Ring Doorbell "{devicename} isn't responding" in Echo Show

Yall have the same lousy replies like this isnt a RING issue. Clearly this isnt just randomly happening to people in random places that have spent hundreds of dollars with your company. Yall need to fix this. I didnt buy these cameras for 35 secs of surveillance then 35 seconds of buffering and cutting out

I assume this has never been resolved?

I purchased a ring door bell camera and an echo show 8 and have the same issues as others - connects when it feels like it. It does however work correctly through the phone app

I have the same issue with mine. So frustrating! It takes far to long for my Echo Show 5 to connect. Too many times a person has been at the front door before the Show even connects.

One thing I found a bit odd…just today I received a survey from Amazon inquiring if I would be disappointed if Alexa and Ring parted ways or what they could to improve. Maybe they ARE working on it???

Ring are pretty quiet on this thread, so clearly Ring do not “support” seeing camera’s in Alexa Show!

I have the same problem “Waiting on Ring.com…”.

  • i disconnected and reconnected the skill… no fix
  • The ring app works fine on computers and mobile phones, so it not ignore the “solved” above.

Hi there, neighbors! If you have not already tried, please disabled and re-enable the Alexa skill. The next best step, while still in the Alexa app, select your Ring device and toggle the Announcement toggle off then back on. This should update the name displayed. Please let us know if this worked! :slight_smile:

I deleted Ring as a skill and re-discovered the device and added it back. I also toggled between enabled / disabled several times. I also toggled back-and-forth several times on the announcement selection. None of this allows me to view my ring doorbell from my Alexa Show. Sooooooo frustrating. Please resolve!!

Problem:

I was getting the “already showing to other devices, can’t add to conversations” (something like that) when asking Alexa, “show the front door” for the Ring Doorbell. It wouldn’t show the camera feed on Echo, only on a tablet/phone. Spent hours restarting, reconnecting Doorbell, then factory resetting Echo device, disabling/enabling skills, etc. and none of that worked.

FIXED:

Thanks to the tip from this poster hours ago:

Go into the Alexa app (not the Ring app) > Devices > All devices > select your camera > and then in the top right corner there’s a trash icon (which is way too easy to not see considering other Amazon interfaces show the remove option as text). Trash/delete that device. Then click + to add a new device > Camera > Ring > it will scan 45 seconds and hopefully find your device and proceed to add it.

That fixed it for a short while. However, the problem came back suddenly after making changes to device settings, so I did the process again and so far it works. It could easily flip back again to not connecting, but at least the fix works temporarily. Something is obviously buggy with Amazon’s Echo or Ring software for this “skill” and needs to be addressed. Good luck!

I’ve the same issue. “Alexa, show front door.” I hear the sound from my camera, but the camera does not display. Screen says “Waiting for Ring.com”. After approx. 20 seconds, Alexa says “Hmmm, the camera isn’t responding.” and closes the connection.

I can see my front door camera in the Ring App on my cellphone while connected to the same wifi access point and SSID with almost no hesitation.

I will try the things I see noted here.

Thanks.

I disabled the Ring Skill and re-enabled it and it did not solve the issue.
I can view my camera in the Alexa app on my cellphone and in the Ring App on my cellphone while connected to the same access point as my Echo Show 10 G3. Why can my Echo Show G3 not display video??

Hi there, @mijanko! Great work on covering those steps. As video is connecting and working when manually viewing through the Ring app, this is a great sign that your network is delivering video and your Video Doorbell is working as intended. I recommend moving your Echo Show closer to the access point to avoid any interferences. Please also ensure this Echo Show is connected to your 2.4 Ghz wifi, rather than 5 ghz. I hope this helps! :slight_smile:

Same issue here. Worked fine for months now I have sound but no video about 15 seconds goes by and it says camera not responding.

In my alexa app I can not view my cameras either.

Updated app
Restarted internet
Uninstaller skill
Deleted cameras
Reinstalled skill
Discovered cameras
Announcements are on
Checked router settings
Recharged all cameras

At a loss… works fine in ring apo

1 Like

I have the same issue. Alexa show 5 the video only when initiated from Alexa. If I ring the door bell then Alexa doesn’t do anything. This is frustrating. Is this Alexa issue or Ring issue? Ring app works ok. There are some delays by a few seconds sometimes. However, the Alexa integration appears to be a failure.

2 Likes

Exact same issue as Alexmpcs. Ring is trash, refuse to fix their issue

1 Like

I’m having the same issues between ring wired security camera and my alexa show 10. waiting for ring.com and too many people in the conversation…
No problems with cell phone and ring app. restarted the amazon device. no luck…

I have an identical issue to this.

I decided to try this…

Connect my echo show to my mobile data connection on my phone via hotspot.

Then try “Alexa, show me the front door”

Worked like a charm. Live feed came up straight away.

Obviously, this is not in any way a solution, but, it may help developers or admins who are reading these threads figure out a solution. That is IF they read these threads. Judging by some comments on here they don’t read or care about it?

mijanko,
Ring should have been all over this when it first became prolific. Few consumers of home electronics have the expertise or know-how to troubleshoot issues like these; Fortunately, I am an electrical/computer engineer and do not have to rely on someone reading a script to me after hours/days of wondering what has changed.
I have been able to duplicate and predict this failure after some troubleshooting of my network with a Layer 2 analyzer. If you router has dynamic MTU then you’re going to run into problems if your packets are fragmenting below about 1425 (add 28 for header etc. and the actual low end is about 1460 or so). It really depends on your network and the upstream link. If I set my MTU manually at 1500, this issue goes away. I can even bring it down to about 1460, but that’s about where RING throws up. Yes, oddly enough, if your MTU is below about 1460, this is the very problem you will encounter.
You can prove this to yourself by turning off Wi-Fi on your phone and using the Alexa app with a good 4G LTE or higher connection. Your video in the Alexa app on your phone will work all day long. Now, turn off cellular and turn on Wi-Fi and you will find that you get the symptoms you wrote about, again. This the easiest way to test your network as few people have an alternate Wi-Fi connection for the Echo Show devices so they are reliant on your wireless network for connectivity.
If you know how, try setting your MTU to 1500 and the problem should go away even though you may pick up some packet fragmentation. If it’s too badly fragmented, then you will suffer some throughput losses.
My question is how is this an on-going issue for months/years and Ring hasn’t addressed it?
Also, Ring, why is the video stream dependent on a fixed MTU size of 1500 in the Alexa app (Ring and Amazon are one and the same so far as I’m concerned)? Audio makes it through just fine and the video quality/stream isn’t so high that 1500 would be required. It seems to me that you guys have hard-coded the packet size to 1500 and any router/network that doesn’t support that won’t work inbound on any Echo/Alexa device the is Wi-Fi dependent. The Ring App displays the stream even when the MTU is at 1400, so what’s with other Amazon devices/apps not supporting lower MTU packets?
This is predictable and demonstrable; Don’t just ignore it. It should be an easy fix in firmware and app updates.

1 Like

Kev0,
You’re on the right track even if you don’t understand what’s happening under the hood.
I responded to another with what I discovered and how I remedied the same issue on my network.
I’ll post it here, again, since these threads are nearly impossible to follow (by design??)


mijanko,
Ring should have been all over this when it first became prolific. Few consumers of home electronics have the expertise or know-how to troubleshoot issues like these; Fortunately, I am an electrical/computer engineer and do not have to rely on someone reading a script to me after hours/days of wondering what has changed.
I have been able to duplicate and predict this failure after some troubleshooting of my network with a Layer 2 analyzer. If you router has dynamic MTU then you’re going to run into problems if your packets are fragmenting below about 1425 (add 28 for header etc. and the actual low end is about 1460 or so). It really depends on your network and the upstream link. If I set my MTU manually at 1500, this issue goes away. I can even bring it down to about 1460, but that’s about where RING throws up. Yes, oddly enough, if your MTU is below about 1460, this is the very problem you will encounter.
You can prove this to yourself by turning off Wi-Fi on your phone and using the Alexa app with a good 4G LTE or higher connection. Your video in the Alexa app on your phone will work all day long. Now, turn off cellular and turn on Wi-Fi and you will find that you get the symptoms you wrote about, again. This the easiest way to test your network as few people have an alternate Wi-Fi connection for the Echo Show devices so they are reliant on your wireless network for connectivity.
If you know how, try setting your MTU to 1500 and the problem should go away even though you may pick up some packet fragmentation. If it’s too badly fragmented, then you will suffer some throughput losses.
My question is how is this an on-going issue for months/years and Ring hasn’t addressed it?
Also, Ring, why is the video stream dependent on a fixed MTU size of 1500 in the Alexa app (Ring and Amazon are one and the same so far as I’m concerned)? Audio makes it through just fine and the video quality/stream isn’t so high that 1500 would be required. It seems to me that you guys have hard-coded the packet size to 1500 and any router/network that doesn’t support that won’t work inbound on any Echo/Alexa device the is Wi-Fi dependent. The Ring App displays the stream even when the MTU is at 1400, so what’s with other Amazon devices/apps not supporting lower MTU packets?
This is predictable and demonstrable; Don’t just ignore it. It should be an easy fix in firmware and app updates.

1 Like

Still hitting this issue in 2022, even using Ring’s own doorbell wifi extender. Maybe somebody needs to tell them not everybody on earth lives within the low-latency bubble around Seattle?

Ring servers aren’t only located around Seattle.

You couldn’t tell that from the latency in Orlando that I don’t see at all on friends’ setups in Snohomish.