Ring Doorbell 2 Live Not Activating

I recently installed a Ring Doorbell 2 and it worked ok the first day, but today the Live view will not activate.
The router is about 4ft away.
Upload and download speeds both over 18mbps.
I’ve reset the router and tried the Live Activation on 2 mobile devices in the house, but with no luck.
I’ve turned off the wifi on my phone and tried again with data - no luck.
The doorbell does record videos of motion and calls, and I can see these ok in the app, so it seems the wifi connections are ok.
Can anyone please help with why the live activation is not working?

That’s weird you say that as mine has done exactly the same today. What internet provider do you use? I’m on Virgin. Thanks

Hello and thanks for the response.
I don’t think the issue is related to Internet provider as I tried the Live view using phone data (wifi turned off) and the problem was the same.
Strangely, the problem has gone away after I downloaded a wifi app and ‘pinged’ the device.
My worry is that it might be somehow ‘going to sleep’ if not used for a while and has to be ‘woken up’, but that’s just speculation.
Today it is behaving itself, ? but if it repeats this behaviour then Amazon will be getting it back.