Ring Doorbell 1 security screws

I was trying to take off the doorbell to recharge and the Security screw on the left of the pic will not unscrew; it’s stuck and keeps rotating. Possibly rusted inside?
How to take it off without uninstalling the mount on siding? Thanks!

Hi @Bernadette2015. Stripped screws can be tricky! You can try a few things to get it removed. First, try a pair of pliers and see if you can manually unscrew it. You can also trying putting a rubber band over the screw head, and then try to use the screwdriver as normal. Let me know if this helps!

Hi, So I tried both suggestions and was not successful. It keeps rotating and the screw will still not come off.
I was hoping not to take off the mount, but may come down to it, which will be a pain to do. I’m hoping you or anyone in the forum that has something else in mind to get it off.
I’ve recently started using the Ring doorbell this year and maybe it became defective; possibly the screw rusted or some sort?

Hi @Bernadette2015. There can be a whole variety of reasons this could happen. If you are unable to get the screw out, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.