Ring devices ignore closest Deco X20 and keep connecting to Main Deco

Deco X20
Hardware Version: V2
Firmware Version: 3.3.65

Hello. My Ring Chime Pro ignores the Deco X20 sitting right next to it and keeps connecting to the main Deco, 2 rooms away.

From what I read:

  • It can’t be the band, as the main Deco band is 2.5/5 GHz and Ring devices connect to it fine.
  • I disabled Fast Roaming and Beamforming, but again no luck.

Any ideas?

Thank you

Hi @user47769. I do not have any basic troubleshooting steps to offer that will help with your concern. Perhaps our advanced technical support team can assist with this. Give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

@user47769 any resolution to your issue? i got a new deco system about a month ago after upgrading from my google wifi and my ring cameras and doorbell has been terrible with these Deco devices. i may consider switching back. i turned off beamforming and fast roaming as well. if you want to connect directly to the deco you prefer you can go into devices on your deco app and click on the ring chime from the devices (youll first need to find the mac address from your devices in the ring app) then in Deco, click on the ring chime pro mac address and select the deco device you want to connect to and turn off mesh wifi for that device. even after doing all this myself for every ring device im still having major issues.

I lost weeks to this and finally solved it. For some reason the chime firmware does not like “high” IP addresses. My deco router was set to issue IP addresses in the range of 192.168.1.x and actually ended up at 192.168.1.190.

I change the IP range on my router to be 192.168.0.x and also assigned the chime a fixed IP address of 192.168.0.4 (nice and low for good measure). Now works a charm. Advanced settings in app.

1 Like

Thank you for sharing this solution @user73987! :slight_smile: