Ring chime will not connect to wifi

My ring chime setup fine the first time, but now it has lost its wifi connection. I am trying to reconnect it, but I do not get the flashing light indicating setup mode. I’ve tried pushing the reset button for five seconds and also tried pushing it for 15 seconds, but nothing. Do I have a bad chime?

Hi @sjvalenta. Try unplugging it for 3 minutes then plugging it back in close to your internet router (you can move once connection is complete). Give it about 2 minutes to boot up, then try pressing and holding the reset button for 20 seconds. Using this method forces a hard reset on the Chime and that should allow it to enter setup mode. If this doesn’t work, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Let me know if this helps!

After trying all of the suggestions presented here I must say that this issue is simply a case where RING has updated the device firmware to make it obsolete.