Ring Chime Pro no power

Same issue here. I can definitely say, cheap engineering and quality control. I am an engineer who design chips (processors). I can definitely say that this is either stupid design or cheap parts being used on PCB or they didn’t lifetime test on these products. Most probably the 120V AC to DC voltage of PCB is a compromised design. Shame on Ring that they couldn’t design a quality product that’s so simple (all it has to do is produce a sound when someone presses the button outside). I will keep away from any of their other products that require more engineering.

I have Ring Chime Pro (1st gen), and it too stopped glowing blue. As far as I could tell it seemed like it wasn’t getting power. But I found that after resetting it, it still works, other than the blue light.

Another issue is that when resetting it, you have to hold the reset button down continuously, but it’s easy to accidentally allow to pop back up without realizing it, especially if you use a pen. So don’t use a pen.

So this is what I recommend. It worked for me:

  • The Chime should be plugged in to the wall outlet while completing the following instructions.
  • Hold down the reset button with the flat part of your finger. You should feel it depress. (DO NOT use a pen or screwdriver to push it down like the it says in the instructions.) Hold it down for 30 seconds.
  • Release the button and wait a few minutes. You will not see the blue light, but just pretend it’s glowing as expected. Eventually it should talk to you and tell you it’s in setup mode.
  • Use the Ring app to connect to the chime, and to connect the chime to your device, as it says in the instructions.
  • If it doesn’t work, unplug it, plug it back in, wait a few minutes, then repeat the above instructions.

Same issue, Ring chime doesn’t glow blue. Tried the above suggestions, no luck. Finally I removed the Chime device from my network completely then reinstalled it from scratch, pretending that the “Ring” was glowing and flashing. Set it up manually by connecting to my home network, as it was previously. This Chime links to a Ring doorbell. Finally the Chime reconnected and it seems to be fine now, although it still doesn’t glow blue.

I have had this system less than 3 years, had it professionally installed (cameras hardwired) and it’s the third time one of the chimes has malfunctioned somehow. Had to replace two already. Each time had to fight a little with Ring support. I have found their equipment to be utter crap. Faulty equipment that goes bad after a relatively short time. Setup systems that are confusing and don’t work exactly as they instruct you. Motion detection zones that pick up what you don’t want them to, regardless of how you tinker with the settings. I finally gave up after 2 years and paid to have a professional camera system installed, didn’t renew my Ring video recording subscription, and now just use the Ring system to alert me when people come to the front and side doors. We have a professional home monitoring alarm system as well so I think all the bases are covered. I wish I could get back the money I spent on the Ring system, it’s a complete waste.

Same issue. I’m getting the Nest instead