Ring Chime offline no lights

Hi There,
My chime went offline a few days ago.
looks like its not powered on. when i unplug and move to another working socket a red light flashes briefly then turns off.

ive tried running the setup again but get nowhere. the reset button does nothing its like the unit is dead.

have tried to call 00 800 8700 9781 and when its going through the language options i press 1 for english and nothing happens it just goes through all the language options and then hangs up.

please help unit is under a year old and am in Ireland.
thanks in advance…
BF

Hi @BF! It looks like you’ve covered everything here for getting your Chime to power on. Just to confirm, please ensure you are holding the setup button on the Chime for 20 seconds., in order to reset it.

If it is still unresponsive, reaching out to our support is certainly the best next step. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

The number you shared for your region looks correct, in which there is also a “worldwide” number in the contact list as well, that might help. Feel free to let us know how this goes!

Thanks Marley, managed to get through on that number later that day. Replacement chime enroute.

1 Like

Glad to hear this, and thank you for updating us, @BF! :slight_smile: The Chime is definitely an important part of an optimal Ring setup, and we are happy to hear you enjoy it.