Ring Chime not connecting to WiFi

Hi all, I have just bought 2 Chimes to connect to my Ring doorbell. Neither Chime will connect to my home wifi. They are both flashing green like I believe they are supposed to before connection and I have tried to setting each Chime up close to my router and also close to the doorbell. Still they don’t connect! have also turned off mobile data on my iPhone and deleted and reinstalled the Ring app.
Please help!

Hi @Hannah87. The flashing green light pattern you’re seeing is likely indicating that the Chime is in setup mode. If possible, can you clarify which part of the setup it appears to be failing at? Feel free to attach a screenshot as well so I can take a look. A basic troubleshooting step that may help is to reset the Chime by holding down the setup button on the side for at least 15 seconds. Once that’s done, you can try and walk through the setup again and see if it is successful. Let me know if that’s helpful! :slight_smile:

I am having the same problem. I recently received a Ring Chime (2nd Gen) and have not been able to setup after trying for several days.

In between tries, i’m resetting the Chime with the reset button.

The Chime is located within 10 feet of both Ring Doorbell and the Modem.

I scan the Code, and click on “Light is flashing Green”

I select Yes for when asked if connecting to my Wifi.

I get the message, restoring your phones internet connection.

A message says it is connecting to my wifi

then i get an error message.

Hi @Cibabo. Thank you for sharing some insight on what steps you’ve tried so far concerning your Chime. Since you’ve walked through several of the basic troubleshooting steps and are still receiving the same error message, it may be best if you reach out to our support team directly. They’ll be able to take a closer look and provide more in-depth troubleshooting steps to get this resolved. You can give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Feel free to let us know what solution our support team recommends, as it may help other neighbors as well! :slight_smile:

I’ve had a Ring2 doorbell and Chime for 18 months now when the Chime stopped working. The Doorbell2 is working fine, it’s just the chime that has a problem. I reset everything but the Chime refused to play ball after numerous attempts. I contacted Support and was talked through the Chime installations by Amber without success. The phone conversation was cut off for some unknown reason and Amber did email me for my phone number even though I could not reply as her email to me was a no-reply email?? Anyway, my wife and I tried numerous times again to no avail where the Chime would not connect to WiFi as it never got to the point of asking for the Network and Password. We then contacted Support again and talked to Geo. He talked us through the installation again with the same results. My wife and I were getting more frustated by then as the Chime just would not connect even with Ring’s help. Geo even emailed me a link for setting up the Chime. Followed it to the letter with the same result. Ring needs to realise that if the item does not work it is faulty and admit that. No such thing from Ring. We decided to purcase the latest Chime and installed it without any issues. This time the new Chime asked for my Network and associated Password.

So that tells me that the earlier d.mn chime was faulty and Ring should admit and not imply that people don’t know what they are doing.

There are numerous posts about this problem. I returned the item to the store and was told it was out of warranty. There have been Chime returns to this store previously.

On a new install I got stuck at “Chime is connecting to (wi-fi SSID)” but the light turned from blue to red and several minutes passed with no change. Repeatable.

I had answered Yes to the question, “You used (SSID) before, use it again now?” So I tried starting over again and answering No. Then I selected that SSID and entered the password, and the process was finally successful.

1 Like