Ring Chaim Pro Installation issues

Iv’e changed my Router and home wifi address
All Ring devices reinstalled OK except Ring Chaim Pro !
Tried several times to reinstall the Ring Chaim Pro , Sometimes its connected to Ring wifi address and sometimes not.
Turned off and on , disconnect from mains power and tried agin. NO GO .
Any help will be appreciated.

Try resetting the Chime Pro by holding the setup button in for 20 seconds. Once complete, please ensure you’ve chosen an outlet that is well within range of your wifi router and attempt another setup from there. If possible, try using another mobile device for the setup process. I hope this helps! :slight_smile:

Thanks.
Tried these actions. No go.
After holding the setup button in for 20 seconds is there any sign that the Chaim pro finish reset ?

Sometimes the Chaim pro is connected to my home Wi-Fi and finish setup.
But then it say that it’s not connected.
The lights is blinking Blue and Green after that.
Please advise
Thank you

Hi @Ronen. A Blue and Green alternating flashing light is an indication of a Firmware update or a Factory Restore. I suggest removing it completely from your account, performing a Factory Restore and then setting up up again. If you continue to have issues after that, please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.