Ring app does not find Echo4

I recently purchased two Ring floodlights and an Echo 4. I am planning on using the Echo 4 as the bridge to control the lights. I have enabled the Ring skill in the Alexa and connected my Ring account and my Amazon account. The Echo 4 is set up and working fine. However, the Ring app does not see the Echo 4 at all. It tells me I don’t have any compatible devices in my Amazon account.

Has anyone encountered this? I read elsewhere that the addresses in the two accounts must match exactly, but I don’t appear to have control over them. The Echo adds 4 digits to the end of my zip, but the Ring app does not.

Hi @Bluejayvalley. Are you able to confirm which Echo you have, whether it is the Echo Dot 4th Gen or the Echo 4th Gen? If it is the Echo Dot 4th Gen, then that is why it is not working; it has to be the Echo 4th Gen. If you do have the correct one, can you try setting up your Smart Light and see if during the set-up process it asks if you want to use your Echo as a bridge? Let me know what happens.

Had a busy week at work and am just now getting back to look at this. I definitely paid for an Echo 4. I measured it, and it is the dimensions an Echo 4 - not a Dot. But when I go through the smart lighting setup, the Ring app still does not recognize that I have a compatible device.

1 Like

I have the same issue, this does not work!

1 Like

Hey neighbors. This Help Center article here has information on how to use your Echo device as a Ring Bridge. Ensure that the Firmware on your device is up to date in addition to having an up to date Ring app. I hope this helps!

Alexa says her software is up to date. I have followed the steps in the suggested article, but since the Ring app believes I don’t have any compatible devices, I can’t proceed very far.

Hi @Bluejayvalley. What type of phone are you using, and what version of the Ring app is installed? Can you share a screenshot of the error you are receiving? Have you tried this setup with a different device?

The version of the Ring app I’m using is 5.56.1 on an iPhone XR.
I added a screenshot that shows what I see when I try to add an Alexa device:

Here what I see when I try to add a Smart Lighting device after scanning the QR code :

Hi @Bluejayvalley. Thanks for this information. Upon sharing with this my team, they’ve asked what the firmware version of the Echo device is? If the firmware on the Echo device is not up to date, you can get the error you are getting. You can find that information here. Additionally, when you open the Ring app, tap the Menu button in the upper left corner, then tap your Location at the top of the Menu. From there, confirm that you are on the correct Location and that a duplicate Location has not been created by mistake. This can happen when adding devices. Let me know if this helps.

Following - I have the same problem, but with an Ring A19 bulb. Using a brand new (today) Echo 4 not Echo Dot. It’s up to date. Disabled 5GHz WiFi on my mesh system. Ring skill enabled as I already have a Ring doorbell. It just won’t find the Echo when the Echo is in discovery mode. Thanks

I verified that the Echo 4 has the latest software listed on Amazon (v 8289072772). And I checked that the Ring app only lists a single location. I even figured out how to edit the address Ring automatically set so that it matches Alexa’s address exactly, including the extra 4 digits in the zip code.

But still no change. The Ring app still does not not see that I have an Echo 4.

Hey neighbors. If your Echo device is on the correct version and you’re on the correct Location in the Ring app, you shouldn’t be receiving this error. I’d recommend following up with our support team from here so they can take a deeper look and offer more in-depth troubleshooting assistance. You can give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.