Ring 3 updates after every press of doorbell

Got a brand new Ring 3 and after every press of the doorbell or motion detection the light turns white and does an update. I’ve tried resetting it a couple times and it keeps doing the same thing. It’s useless for about 5-10 minutes after it starts the update.

1 Like

I have this same problem. Found another user with the same issue on Reddit.

I bought 2 Doorbell 3s last week and both go into FW update mode after being activated. Ring sent me replacement units on Christmas Eve and those units have the same problem at all. Tried switching routers and disconnecting my Amazon account but neither solved the problem.

Hi neighbors. If your Video Doorbell is stuck on a firmware update, this means it’s likely not able to successfully complete the update. When you reset your Doorbell, try doing so close to the router, and ensure that you are holding down the setup button for at least 20 seconds. If this problem persists and you’re unable to get your Doorbell up and running, please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

My daughter’s ring is having the same problem as reported by @bmlaw. The solution posed by @Caitlyn_Ring does not help. This is not a normal firmware update. The Ring app is reporting that the firmware is already up to date, so it shouldn’t need to do the update. Even it was scheduled for an update, it should be trying that during off-peak times, not every time someone rings the bell.

We contacted customer support. So far that has not helped. Like ea95, they sent a replacement, but we are having the same issue as before.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.