Ring 2 battery won't charge. Been on charge for 2 days and still nothing

Hi. My ring 2 battery is only 5 weeks old and says 5% charge. I tried charging using usb cable and usb plug for 12 hours and now the battert syas 2%. The amber and green lights are still on. Tried 3 differemt usb plugs and cables and still wont charge. can someone please help.

Thanks

Hey @Toddy1964. It seems your Doorbell’s battery is not holding a charge whatsoever! If you have another battery or could buy another one, I recommend doing this to see if a new battery that can hold a charge will help power on the Doorbell and keep it on. In the event you do not have another battery or a new battery doesn’t seem to help, I recommend reaching out to our support team for further help.

If you need the support team, please read our response to COVID-19 here to see how to contact support. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. Let me know how this goes! :slight_smile: