Remove Device button not working

I set up a chime under the wrong address. I’m trying to remove it, but the Remove Device button won’t work. It’s visible, but when I touch it, nothing happens. Any ideas?

Hi @Dchaney14. What version of the Ring app do you have installed? It is possible that it is not working because you need an app update. If your Ring app is up to date, but you’re still unable to remove the Chime, try uploading a screen recording of what is happening so I can share this with my team.

1 Like

@Tom_Ring This is also happening to me. I came here looking for an answer as I did the exact same thing. When I go to remove the chime I cannot click on “remove this device” under the chime’s general settings.

Hi @ColeyR. In order for me to look into this, I’ll need the same information I requested earlier. What version of the Ring app is installed? What type of phone are you using and what OS is installed? Can you share a screen recording of what is happening? This information will help my team dive into this.

1 Like

I have the exact same problem. Sold our house, and I was able to remove our doorbell and cameras, but the button for the Chime is not responding.

I have iOS app version 5.51.0

Hi @TerryP1. When you press the button, does it show up in the Ring app as a Missed Ring or Answered Ring? If so, I would double check the wiring in your Doorbell circuit. What model Doorbell is this happening with?

Hello @Tom_Ring and @TerryP1

I have been having the same issue, first i wasn’t be able to change the name of the device so i reconnect it and then that option disappeared and i wasn’t able to delete the device and start over. Everything is on the latest firm where and latest IOS.

Bram

Hi neighbors! If you’re not able to remove your Chime from the Ring app, please give the following troubleshooting steps a try:

  • Ensure both your Ring app and your phone’s OS are fully updated, then try to remove the Chime from the Ring app again.
  • Attempt to remove the Chime from the Ring app using a different smartphone or tablet, if you have access to one. If you’re on iOS, try using an Android device if you’re able to, or vice versa.

If you’re still unable to remove the Chime, please follow up with our support team at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support. I’ll be marking this post as the solution so other neighbors can easily find the suggested troubleshooting steps, as well as how to contact support for further assistance. :slight_smile: