Problem with Ring Floodlight Battery after battery change

Folks - I had three of these set up in a group in my backyard, they have been working properly for almost two months. The batteries in all three needed replacing, not exactly an unexpected event. So I replaced them with fresh, never used batteries.

The first light flashed twice with the new batteries, and was immediately showd up in the app with battery at 100%, and able to work in the group as programmed. This is the way I expected them all to act.

The second light flaashed twice, but for some reason stayed offline, like it could not find the WiFi or the Bridge. I tried removing the batteries and reinstalling them, no joy. I deleted the device from the app, and then used setup to add it back, then added it to the group. A few extra steps, but easy enough to get the light back to the way it was functioning pre-battery replacement. So all good.

And then there is the (insert bad words) third light. It did not flash twice with the new batteries, and it also remained offline in the app like the second one. I deleted this device from the app, and tried to add it back. Then the problems started. The app would try to find the light, tell me it was unsuccessful, then suggest I hold down the reset button for 5 seconds (which I did), then suggest a last resort, removing the batteries and reinstalling them (which I did). The app then seems to think it has found the light and starts installing an update - and when that update finishes it kicks me back to the previoud screen that suggested the battery remove/reinstall. During the update step, I can see a “DFU TARG” device connected to my phone’s BT.

The third light never gets added to the system - and repeating the setup process yields the exact same result (all the steps listed above) every time. I have tried at least 4 sets of new fresh batteries , I have powered off/on of my iPhone in case it was a BT issue, I have tried the device add from in the group, and from the devices listing, I tried adding by scanning the QR, and by manally entering device number and lastly I have done a power off/on cycle on the Bridge. Exact ame result every time - no joy

I did verify that the device number on the battery cover matches the one in the battery compartment.

And remember that this light was working just fine when I installed it back in November - it seems the battery wearing down and being replaced has somehow bricked it.

Sorry for the VERY long post - I was thinking the details may help someone far brighter than me to isolate the issue. I have not tried to contact Ring support - I was trying to leave them alone through the holidays - I had this mental image of them being inundated with calls.

Does anyone have an idea what this might be, or other things I should try to either make the unit work, or to isolate the problem further?

Thanks in advance for any ideas…

Hi @RWD. It sounds like you’ve run through all of the basic troubleshooting steps that I would have recommended to resolve this concern. In this case, the next best step would be to touch base with our support team directly so they can help isolate the cause and find a solution. You can give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. :slight_smile: