Please help

My Ring chime will not pulse slowly to enable me to connect to the WiFi. Tried the 5 second reset tried the 15 second reset. All it dies is pulse 3 times then off for about 60 seconds, then pulses 3 times again. Very frustrating!

Hi @Bigdog666! The 15 second hold of the setup button should result in successful reset. Once complete, pressing the setup button once after waiting a few moments will enter setup mode. Although it sounds like the lights are not matching setup mode, try completing a setup in the Ring app to see if it allows a successful connection. Trying another outlet in the home can also help in case the concern is power related.

If this concern persists, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.