Older versions of app

Hi All,

Is it possible to install an older version of the ring app? Currently I have version 3.49 and it works fine.
Now I want to install the app on a second (same model of phone), but the new version of the app is no longer compatible with my phone. Seems I cannot select an older version.

Thanks in advance.
Peter

I’m cancelling my service because the app is no longer compatible with my phone. I’m not spending hundreds of dollars on a new phone just to use this product. I now have a useless doorbell and indoor camera. What a waste of my money!

Hey neighbors, you cannot download an older version of the Ring app due to security reasons. It is important to use the latest version of the Ring app as it will ensure you have the latest bug fixes and security updates. You can find more information on mobile device compatibility here. If your phone is unable to be updated to the required version of either iOS or Android, you won’t be able to download and use the latest version of the Ring app.