Not Able to Subscribe to Protection Plan

Everytime I go to the Ring website location to subscribe to a Protection Plan, it takes to a page with a message that states “Once you set up a plan or trial, you’ll see it here” and “Get Set Up with the Ring App.” I’ve looked everywhere in my Ring App but can’t find where I need to go to subscribe to the Protection Plan. Please post sign-up directions.

Have you tried signing up on Check out thislink and let us know if you’re able to sign up there. May we also ask where are you located? We’ll get this information over to the team for review. Thanks!

Unable to buy basic plan as well. Signed in via, shows my location and states “no plan needed” 2nd window says “no device”


Hi @cluffman ! You need to set up your doorbell/device first to get a plan. Follow these steps in setting up your doorbell: :slight_smile:

1 Like

Doorbell is already set up and shows at my address, are you saying I have to set it up again? If so do I delete the current one showing?

I just deleted the initial install, reinstalled and I’m getting the same message. Showing doorbell at my address, I request to sign up to the Basic Plan and it says nothing installed at my location?

1 Like

My RING doorbell was installed over a year ago. I tried signing up for a plan then and, over the course of several months, it never took! I never got billed, I never received email (except to purchase my RING products!).

My “dashboard” and/or menu on my app does not have an option that will allow me to subscribe! And please don’t tell me that I’ll have to reinstall the same doorbell again (was told to do it three different times!)

With the size of the advertising budget being what it is, maybe a couple of $$ could be set aside inthe budget to allow us to subscribe to a plan on the website.


Not too hard to find on app and website. See screenshots.

1 Like


1 Like

I saw your replies initially. I tried both the app and the website with identical results! Then, over the course of more than a week, I tried working with tech support. _THEY _were unable to determine the program. I attempted each and every suggestion, directions, etc., he or she made. Until I was told to change my password. When I did, the system would not recognize EITHER my old or new password. And that was the "straw the broke the back of this camel!

I politely informed the agent that I no longer had any interest in working with Ring, its products or personnel.

I’ve been working with A/V and electronics since we still used 2-inch wide videotape and with computers, including building, repairing, seling and consulting since 1984. Yet, I was repeatedly told I wasn’t following directions or I would have seen what they wanted to see.

I sent a separate email to the Support team advising them to keep the $10 that I to pay for the first month, before I could move ahead to attempt to perform the setup with tech support. I asked them to confirm the removal of my credit card from their data.

I have not received a confirmation, but I did receive an email telling me my request was forwards to the "Account Logistics Team, on December 13th.

I do thank you for attempting to assist me the the Ring owner with out problems, but some of us do know what we’re doing with computers and apps, but sometimes, even they don’t work as expected.

1 Like

Been trying to subscribe to protection plan and not able to

1 Like

ME TOO!!! I’ve been trying for several days with no success. Get the same message others get; screenshot included. My account is updated and I used the 30 day trail. Now I want to subscribe but cannot.

1 Like

I know this problem all too well! I tried for over a year to join, but the website always replied with a problem and was unable to do so. Then I called tech support and got bounced around there, as well.

I had all the necessary info at hand. I tried all the online help recommendations, also to no avail. It got to the point that I knew I was wasting precious time that I could be using properly, rather than spending a couple of hours per day, trying to setup the account.

Finally, I got connected, but then my password became corrupted in their system, and I had to go through the process of re-establishing a new password. And that was another horror show, as no matter which password (I use a top-shelf password software program, so I only need to know one, master password) it wasn’t accepted. Finally, I just walked away from here and figured I have one of the most expensive doorbells that does nothing but ring, in my neighborhood.

Try going to support. Personally, with nearly 40 years experience with computers and, as a consultant to small businesses and consumers, I was amazed at how screwed up this system was/is.

Good luck!

Stay Safe, Stay Well, Stay Home!

1 Like

Hi neighbors - can you go into more details, please? Thank you for the screenshot – that is extremely helpful.

It’s important to remember Ring does not accept any payment sin the form of cash, check, money order or single-use credit cards. Personally, I have heard neighbors running into this problem when trying to purchase a plan with a single use credit card.

Please confirm the details – i.e. if you’re signing up in the App vs Browser, Android vs iOS, and the error you are receiving. Please also confirm you are the PRIMARY account owner. Thanks-- we’ll get this sorted out!

I do not have an option of selecting a protection plan either on my phone app or my computer! I have no clue where to go.

Same! I spent a lot of money for a device I cannot use as it was meant to . And, you cannot get a hold of anyone live!


Because you have no devices on your account.
That’s why…


I have tried the app and my computer. I already attached a screen shot. You cannot purchase a protection plan. Plain and simple. None of the options are available to any of us. We would all like a response from RING. We paid a pretty penny for these products and I understand things are locked down right now, but computers and online help isn’t. PLEASE ACKNOWLEDGE and explain how to get this taken care of.


Why is that? When I did when I had the trial subscription. Who removed them?