No live view

It’s a shame when great technology breaks down after 4years of problem free use, only to find that the problem can’t be solved by Ring and we need to resort to a community hub! I have a doorbell that rings, but shows no video. This happened after an update when I charged the battery. WiFi signal is strong, it’s only 3 metres from the router, I’ve downloaded the rapid ring app. Still no video. Any answers out there?

Hi @Sabre. The Community is a neighbor-to-neighbor forum but I’d be happy to offer some suggestions that may help in this scenario. A great place to start when it comes to video concerns like this would be our Help Center Article here. If the tips in there don’t do the trick, please feel free to share a screenshot of what you’re seeing in the Ring App when you try to view the Live View or video so we can see what you’re seeing on your end. :slight_smile:


Still having problems. I have followed all the advice and with perfect WiFi, fast speed, operation next to router I am still getting no video and also no light on button when pressed. This is so time consuming, I need an fix please?

Hi @Sabre. If the troubleshooting tips in the Help Center Article I shared did not help and the RSSI on your Doorbell looks good, then you may need to contact our support team for further in-depth troubleshooting. You can give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.