New Chime Pro (2nd Gen) Won't Connect To Network

I just purchased a Ring Video Doorbell 3 and a Chime Pro (2nd Gen). The Ring Doorbell is set up and operates fine.

I am having a problem setting up the Chime Pro. The Chime setup seems to go smoothly until it gets to the part where it connects to the Wi-Fi network. After about a minute, the setup fails and the ring light on the Chime turns red. And, I get an audible message that says “Connection failed due to a poor signal - locate closer to router and try again”.

The Chime was plugged into an outlet that was 15 feet from the router and had a direct line of sight with no obstructions. My phone (Android, Pixel 3 XL) says that I have an “Excellent” signal. The router is an ATT U-verse 5268AC. It’s a dual-band router and both 2.4Ghz & 5Ghz are turned on in the router. My phone connects @ 5Ghz.

I called Ring support and they were not any help at all. They just had me do what I’d already done 3 or 4 times before I called them. They also told me that my Chime could only connect @ 2.4Ghz and suggested that I Contact Amazon and request a replacement - which I have done.

I noticed one odd thing during the setup for the Chime. When it was attempting to connect to the Wi-Fi network, it did NOT prompt for a password. The doorbell setup DID ask for a password. Is this normal?

Are there any suggestions to make the Chime Pro (2nd Gen) connect to my network?

Hey @wchettel. Thanks for reaching out to the Community forum! I’m happy to help you out further with this. Just to confirm first, when you were on the line with our support team, did they recommend for you to reset the Chime Pro by pressing and holding the setup button for 20 seconds? I have a hunch that they may have, but want to make sure of that first, as this is a great step to take! When it comes to what you ran into in the setup, were you unable to connect to the Ring Setup Network for the Chime Pro? This may be where the hiccup lies, as this network does not require a password, and after it’s connected to this, it will then prompt to connect to your wifi. If you’re not sure and don’t mind re-producing this, please take a screenshot of the page in the app you get stuck at, and get back to me with that! Lastly, when you have the Chime Pro plugged in, is the green light flashing?

Hi Chelsea_Ring, thanks for your reply.

Yes, they did have me press and hold the button. But, they told me to hold for only 10 seconds. But I held it for 15 seconds. I do not understand what you mean when you say “were you unable to connect to the Ring Setup Network for the Chime Pro?” Everything went smoothly until the Chime Pro attempted to connect to my Wi-Fi network.

I will try again and send you a screenshot of the page where it fails. And yes, the light does flash green at some part of the setup - but not all.

And why was I told that my Chime Pro would ONLY connect to a 2.4Ghz network?

@wchettel Thank you for clarifying that! Please send me over that screenshot, that would be most helpful. In addition, could you take a picture of your Chime Pro? I know you mentioned in your title that it’s the 2nd Gen, but they may have said it can only connect to the 2.4 Ghz network if they were under the assumption it was the 1st Gen, as the 1st Gen could not connect to a 5.0 Ghz network. With a picture of your Chime Pro, I can confirm you indeed have the 2nd Gen and also confirm for you that that one can be set up on a 5.0 Ghz network as well. Please note that you may have difficulties setting it up the 5.0 Ghz network if the Chime Pro is further away from the router, but this doesn’t seem to be the case for you since it was only 15 ft away. Just wanted to make a note of it just in case. :slight_smile:

Hi Chelsea_Ring,

It may be tomorrow or Sunday till I have time to try the setup again.

In the meantime, attached are a few pics of my Chime Pro. The print on the label on the back is so tiny that it’s hard to read. If you zoom in on the left side of the label you will see that it is clearly labeled as "Chime Pro (2nd Generation).

@wchettel You are indeed right! It is the 2nd Generation, so thank you for those pictures to confirm. My apologizes for the agent’s confusion, they must have thought it was the 1st Gen. Also sorry for the delay on a response from me - I am out on the weekends. Were you able to try another setup? Let me know how it went! :slight_smile:

Hello Chelsea_Ring,

I received my replacement Chime Pro from Amazon on Saturday, June 6th. I went to the Ring website to check something about the installation. I saw that they had just reduced the price of the Ring Doorbell 3 to $149. I paid $199 a little over a week ago. I contacted Amazon and they wouldn’t do a price-match refund but they did authorize and initiate a return for the one I just received. I ordered the replacement at the lower price. It arrived Monday afternoon June 8th. I let the battery charge overnight.

So, now I’ve got a new, different Ring Doorbell 3 and a new, different Chime Pro to use. I also have turned OFF the 5Ghz band on my router and reset it. (see attached screenshot).

The new Ring Doorbell 3 gets set up without any problem and works fine.

The Chime Pro still WILL NOT CONNECT TO MY WI-FI NETWORK! I have used a heavy, grounded extension cord to power the Chime Pro. It is sitting 12 inches from my router. The Ring Doorbell 3 is sitting 24 inches from the router. (see attached screenshot). After about a minute of trying to connect to my Wi-Fi, the light on the Chime Pro turns red and I get the audible message that “connection failed due to poor signal, please locate the Chime closer to the router and try again”. A message also pops up on my phone. I’ve done what the message suggests that I do. (see attached screenshot).

I’m getting frustrated! What can I do to make the connection? If I can’t get the Chime Pro to work, the whole thing - Ring Doorbell 3, Chime Pro, and the spare battery will have to go back to Amazon for a refund!

Thanks for your help.

Walter in Davie, FL

Hi Chelsea_Ring,

I was only allowed 2 attachments, so here is the screenshot of the message that pops up when the network connection fails.

Thanks for your help!

Walter in Davie, FL


I’m not as fancy as you - did not figure out how to post from another message but see my comments in the other post you copied this to.

I manage the Wi-Fi network for a global company (200+ sites). I too have an Orbi system at home and it has GREAT coverage inside the house. I kept getting to the network connection and failing. I reset the device for a full 30 seconds and started again.

One key change I made - I did not use the same network I used “before”. I said no to that step and manually selected the same network I had used before. This time it promted me to enter my WPA2-PSK password for the SSID. After I did that, the device connected and worked like a charm.

Let me know if this helps you.



Thanks for that workaround tip. It worked like a charm! My Chime Pro is set up now and working great. I’m not sure if it had anything to do with the problems I had but my Android Google Pixel 3 XL is running Android v10.

Thanks again!

Walter in Davie, FL

1 Like

Hey neighbors! @DiveMedic Thank you so much for your helpful tips and tricks while I was away and @wchettel I’m so glad that worked for you! You all are the best, and appreciate the help here in between neighbors. :smiley_cat: Hope you both are well and stay healthy and safe!

Worked like a charm, indeed! Thanks for the help!

1 Like


I am having similar problems with connecting chime pro to my network. i have successfully set up cameras and they work fine but trying to set up chime pro now. The setup goes to the step where I have to connect to the Ring network. The set does not proceed any further. My device connects to the ring network. I have tried resetting my modem, router, chime pro but no luck. Have tried moving the chime pro around ( closer to the modem or even closer to the camera ), but still no luck.

What else should I try. I am based in NZ.



Hi @Salesh, I’m happy to step in and offer some help here. To clarify, are you able to connect to the Ring Setup Network for the Chime Pro? If so, what happens after? If you’re able to reproduce the concern and don’t mind, please attach a screenshot of where the setup gets stuck in the Ring App. Let us know what lights your Chime Pro is displaying during this process as well. This information will help us get a better idea of what you’re seeing on your end! :slight_smile:

Hi @Caitlyn_Ring,
Yes I am able to connect to the Ring set up network. That’s where the set up goes to. Nothing happens after that. Attached is the screenshot. The chime pro is flashing green all the while.


I have the exact same problem

Hi @Ian70 ,

I have just managed to connect after a lot of trying and reading a lot of solutions. What worked for me was that my devices location was off. As soon as I turned it on I was able to connect the Chime pro to my networ.

Hope that helps.



1 Like

Hi salesh
Yes it helped a little it now goes through the motions to connect so thank you for that

But it now flashes blue for 10 flashes then goes red when it says it is connecting then nothing happens hope admin can help me please

Cheers ian

@Salesh Thank you for letting us know what you tried, and how that worked for you! @Ian70 Based on the light pattern you’re describing, it sounds like the Chime Pro is not able to successfully connect to your wifi network. I’d recommend bringing the Chime Pro closer to your router and resetting it before attempting the setup again. Hold down the setup button on the side for 15 seconds in order to complete the reset, then plug the Chime Pro in near the router and walk through the setup process again.

If that is unsuccessful, please give our support team a call at one of the numbers availablehere. They’ll be able to take a closer look at what’s going on and provide more advanced troubleshooting steps. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19here to see how to contact support. Feel free to let us know what support recommends, as it may be helpful for others! :slight_smile:

8.4.20 - same problem with a Chime Pro (2nd Generation, confirmed)

Maybe I missed something in this conversation but I don’t recall seeing an indication whether the Chime Pro (2nd Generation) must be connected to one wireless band or another (i.e., 2.4 ghz or 5.0 ghz) or whether it may be connected to either. Can someone who succeeded in the setup confirm which network band(s) you were able to connect to?