Motion alerts failing for weeks!

What is going on with Ring? I’d like to know if anyone else is having this problem?

For WEEKS, my ring video doorbell 3 is failing to alert me to MOTION yet there are motion event videos to see in the history.
Also, last weekend a vital doorbell press failed to alert me and I missed a CRITICAL medicine delivery so my naive trust in Ring has had real health consequences. A normal doorbell would have done the job better and then I wouldn’t have missed my prescription delivery. I only knew about that missed doorbell press from my events history which was 09.12 of 17th Dec but now that event has been mysteriously removed by Ring in my app although it is viewable if I login into the ring website…so there are very illogical things going on with the ring server.
Ring status states there was an outage on 7th Dec affecting ring app and login and I DO believe this is around the time when my motion alerts stopped and then I had this intermittent doorbell press alert failure too.
I am now left with still NO alerts at all from motion.
If I wave my hands in front of my doorbell it does not trigger any sound alert anywhere and my chime doesn’t go off and my phone has no notification.
.I never altered any settings …everything is as it should be and for the record I followed every troubleshooting step for ring on android. I cleared app cache and data and ensured app notification is on . I uninstalled and reinstalled the ring app and ALL notification settings in the app are correctly set as always.
This is utterly ridiculous now …nothing changed at my end yet Ring is FAILING to alert me to motion which was the whole point of me getting this doorbell .
I have now wasted over an hour on live chat to ring who having known I contacted them about a problem then wasted my time asking me useless questions only to then say they can’t troubleshoot!
I am sure there is a fault centrally at Ring affecting their software , the app itself or the communication between doorbell and app but then if that is the case how come a doorbell press is alerting me and not any motion ? The app says WiFi is adequate and the battery is fine.

I am so fed up . I live alone and depend on this for my security and now I cannot .

Has anyone else had major failures with motion alert recently?

I do know that someone in my area has also had doorbell press failures recently which did not alert inside the house so I can’t be the only one.
If Ring do not put this right soon I will be really angry.
I am not getting the product functionality that I paid for so this is a breach of my consumer rights as well as a disappointing let down inconveniencing me and affecting me.

Hey there, @MB8. Thanks for sharing all of the steps you’ve taken to remedy this. Usually, notifications can be fixed using the steps in this Help Center article here. Additionally, rebooting your internet router and resetting/reconnecting your Doorbell to wifi should correct most issues. Since this doesn’t appear to be the case, I suggest reaching out to our support team to take a deeper look into this concern with you. Please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support. Feel free to let us know how the support team was able to help!

I have noticed recently a lag in notifications or none at all. I have tried adjusting the range and movement areas. Most of the time it works, but I am noticing more and more failures and am still in the first 30 days of use, so a bit disillusioned.

Mark