Mailbox Sensor Falling Offline—How to get responses from support?

Long story short, I bought the mailbox sensor after it came out. I bought the bridge at the same time. It worked great until about March, when it suddenly started going off-line on a regular basis. After a ton of troubleshooting, I was sent a replacement sensor. However, the same issues are persisting. I’ve done all of the level one and two troubleshooting multiple times, and nothing solves the issue. It seems I either got two defective ones, or the bridge is a problem, or there’s a software issue. However, the other lights paired with the bridge have not had the same disconnection problems.

I’ve called that number many times and spent hours on the phone. Can’t get through to anyone who will help. I’ve been told I need to talk to advanced tech support, but no one responds. I’ve been on hold with level 1 and 2 agents for close to an hour waiting for advanced support before we schedule a call back, but I get no call back.

Does anyone know how to get a response or escalate this with someone in management to get it resolved? I don’t have time to keep calling and waiting on hold and rehashing the issue.

@Chelsea_Ring @Marley_Ring @Riley_Ring can any of you assist with this?

Sorry to hear about this experience, @drjosh. I’d be happy to help with some troubleshooting suggestions, however, it is likely that you’ve covered some of these steps with our support team. Thank you for providing details on what you’ve tried thus far. As the replacement Mailbox Sensor is falling offline, but other devices are not, it would be odd for the Bridge to behave in such a way for only one Smart Lighting device.

I recommend placing your Mailbox Sensor inside near the Bridge for some time, as a test to see if it falls offline still. During this time, please check the Device Health section of the Ring app to confirm all is well with your Bridge and Mailbox Sensor. The Smart Lighting Bridge can be reset, but this will result in all of your Smart Lighting devices needing to be setup again. Check out our Help Center article for steps on resetting the Bridge and more.

For a more in-depth look at this, and if these concerns persists, continuing with our support team will be the best next step. Please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

Thanks for your response. Yes, I’ve tried that troubleshooting previously. Calling the help line isn’t getting me anywhere, as advanced tech support isn’t responding, and the agents who promise to respond via email or call me back don’t. I don’t have time to keep spending hours on hold with support to get a response. Is there a way you can help escalate this so I actually get a response from my open ticket?

The Ring Community is a public neighbor to neighbor forum. While there are Community team members and neighbors here to offer suggestions and guidance, our support team does not monitor this platform. Troubleshooting steps and solutions can be found throughout the Community for most concerns, but instances that require advanced technical assistance is best handled with our support team. If you have still not received follow up, another support team member will be able to view any open ticket and escalate accordingly by phone.

How do I get someone who will actually respond and be able to escalate? I’ve called about 6 times, and no one has been able to get advanced tech support, and no one responds back as promised. Each of the times on the phone is at least an hour with zero progress.

1 Like

Hey, I have the same issue. Were you able to fix the issue?

I’ve had the same issue with the Mailbox Sensor network connection, after a long period of time where it was working reliably. The only thing that worked was to remove the device from the network, then to go through the whole reinstall process again. Other things I tried but which did not work:

  1. Install new batteries in mailbox sensor
  2. Remove batteries and reinstall them
  3. Hard reset of the mail box sensor electronics (holding button down for 5 seconds)
  4. Move sensor closer to bridge
  5. Reboot bridge and re-connect it to network

I just had a similar problem happen with a Ring Outlet. After being unplugged and re-plugged into the wall outlet, it would not reconnect to the network. The only thing that worked was to remove the Outlet from the network using the Ring app, and then re-install it.

The common thread is that just going through a software uninstall/re-install process fixed both issues. Everything else was the same: network, bridge, power, mounting location, etc. As an engineer, it seems likely there is a software bug at the root of this issue. Perhaps it’s associated with firmware updates?

I just saw new responses. The solution was getting a new Ring Bridge. Replacing it (under warranty) resolved the issue.

1 Like