Mailbox sensor and bridge don’t work

Installed bridge and mailbox sensor twice now but it doesn’t detect anything. The bridge says online signal strength is good and it does have a network name. Mailbox sensor says motion detection on, has both motion detection and motion notification on, device health says device status online, bridge status online, bridge to WiFi router signal good, mailbox sensor to bridge signal good, battery level 100%, motion settings I’ve tried medium and high. I do have a linked device set as my doorbell which is colored blue and on to record event. The only thing in event history is mailbox sensor added to system and it just does not work. I need advice. I have uninstalled and re-installed both mailbox sensor and the bridge twice. Thanks for any help. Dave

Hi @ThreeHowls. How are your Light Settings adjusted for the Mailbox Sensor? Try toggling your Light Settings off and testing the Mailbox Sensor to see if this is impacting its functionality. Also, if the Mailbox Sensor is in a Light Group, try removing it from the Light Group. Let me know if this helps.

1 Like

My situation matches the problem statement but the recommended solution is not working for me. - Geoff

Hi @GDE. Try bringing your Mailbox Sensor closer to your Ring Bridge. If it functions normally, this will let you know that there is a distance/signal issue. In this case, you will benefit from changing the location of your Ring Bridge. I hope this helps.

Not sure if it helps or not, but I tried to get my mailbox sensor to detect any motion and I even bought another just in case the one I had was broken. I just discovered that I had to first put it into a light group, and then it magically started to detect motion. Once I removed it from the light group it stopped working.

This page Ring Mailbox Sensor Information – Ring Help says you don’t have to put the sensor into a group but as soon as I set it to “No group assigned” it stops detecting any motion. Once I put it back into a group then it detects motion again.

Very frustrating to say the least :frowning:


As long as its linked to lights mine shows motion but does not Notify me

I had the same experience. I was trying to figure out why my newly installed mailbox sensor was not working all evening! Glad I found this post! It is not stated anywhere that the mailbox sensor needs to be added to a group in order for it to work but that is exactly what got mine working! Thanks user57! Ring please update the instructions to state that you must add the mailbox sensor to a group in order for it to work. If you say that adding to a group is not necessary then point this issue out to the developers so they can fix this bug, so the next person will not have to struggle with getting their mailbox sensor to work.

Ring rocks!!