Lost connection with my wifi even though wifi is fine

The ring bell was slow connecting to my phone and it was even missing some movement outside so i decided to reconnect it to the wifi to see if there was a connection issue. But now it wont connect at all. All other deivces tv etc all working fine but the ring door bell will not connect to my ee wifi.
If all else is working fine why will the door bell not. I paid £90 for a working item that is not working properly.
It started off ok a month ago when i installed it, and slowly over the weeks the signal and delay in connection has got pretty bad, and now it wont connect at all. Ive tried reinstall, ive tried switching off and on wifi, ive tried sitting next to router and its still not connecting.
It just keeps flashing white on the left side of the ring every time i try to connect it to my wifi. I even tried using a wifi extender incase
that was the issue
If anyone can help me fix this before i totally give up i would greatly appreciate it. I cant afford to throw £90 away on something that doesnt work
.

I am experiencing the exact same issue with my RING spotlight cam.

Does anyone have solutions or reasons?

Hi neighbors! You’re on the right track with the troubleshooting steps you’ve tried so far. One more thing I would recommend trying is to reset your Ring device before attempting to set it back up again. To reset your Ring device, you’ll just want to hold down the setup button for at least 20 seconds. After that, try walking through a fresh setup again in the Ring App to see if you can get your device up and running. If not, our support team can help you look into this further. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. :slight_smile:

Hi, two reasons come to mind:

1. Wireless network not operating on 2.4GHZ range
2. Faulty device (faulty wireless card)

1. Wireless network not operating on 2.4GHZ range
The first reason I can think of is your wireless network might be operating @5GHZ instead of 2.4GHZ do you know how to log into your router to check your wireless setup?

If you can see if your router is configured to allow your wireless network to operate on the 2.4GHZ range as that is the wireless network most IOT devices are compatible with to save on battery life.

It might also be worth seeing if your router allows you to create another SSID (wireless network) which you can hardcode as 2.4GHZ.

2. Faulty device (faulty wireless card)
To rule out if the device has a faulty wireless card or not create a mobile hot spot on your phone and go into the hot spot settings and see if you can force the hot spot to operate on the 2.4GHZ range, then try going through the setup stages to connect the device to the hot spot.

1 Like