Linked Account problems stopping integration with Water Monitoring & Smoke Alarms (Tech support is a dead end)

When trying to link amazon to my ring app I get the message your Amazon account is already associated with a ring account.

Contacted Ring Support:

  • This issue with with the Amazon account, please contact our parent company Amazon.

Contacted Amazon Support:

  • The issue is with your Ring account, please contact Ring Support.

Troubleshooting steps taken:
Amazon Account

  1. Removed all Ring devices
    
  2. Removed Ring Skill
    
  3. Cannot link account
    
  4. Verified accounts are not linked at: https://www.amazon.com/ap/adam 
    

Ring Account:

  • Removed Skill
    
  • Cannot link account
    

The skill can be added on the Amazon side, but the Ring side doesn’t recognize the Amazon account.

Issue:

  • The smoke alarms and water monitoring system can’t be integrated.

Is anyone else having this issue?

Should legal action be taken?

Hi @Too_Techy. If you are getting the message that your Amazon account is already associated with a Ring account, then it means you may have already linked your Amazon account with another Ring account. Double check any other possible Ring account you could have made before to see if it is linked there. If you do find it, you will want to unlink it from your Amazon account. Also, try linking your Amazon account with Ring on Ring.com to see if that makes a difference. If you have tried these steps and are still having the same concern, you will have to continue working with our support team for further assistance. You can also reach out to our support team on Facebook by sending them a private message to @Ring.

Tried all of those steps multiple times. Called Ring twice. Escalated twice. The last time I called was a few weeks ago. They’re still trying to figure it out…Oiee!!

Update: Ring support has stated they’ve contacted Amazon and found my account is linked to another Amazon account email ending with “.temp” without the quotes. Note: I own the “Domain Name” so I know it’s my account.

In short, I couldn’t have done what they said I did.

I did research and found that the end of the email is called a Top-level domain (TLD) name. [https://moz-static.moz.com/learn/seo/Domains-page/_large/domain-description-image.png]

The .temp TLD is not in the list of allowed TLDs according to WIKI. See List of Internet top-level domains - Wikipedia

According to Amazon you must verify your email prior to registering account.

I sent emails to Ring support about this and am no longer getting response. Does anyone know how I can escalate this?

I’m no expert, but it sounds like there was some sort of synchronization error that caused a temp version of my account to be created.

@Too_Techy. I suggest contacting our support team by giving them a call once more since your emails are no longer being responded too. If you have worked with them before, there should be a ticket the new support agent can review to help escalate your concern.

FYI: After 9 months with technical support, it was escalated to Amazon (finally found a support person who was on it). They asked for details about the devices and after several weeks it’s been resolved by having Amazon delete the tmp accounts.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.