Lights not working on Ring Flood Cam

I’ve just installed a Ring Floodlight Cam wired. The camera works correctly as does the siren but I can’t get the floodlights to come on at all. I’ve tried the light slider in the Android mobile app and I tried moving under the detector last night in the dark but still nothing from the lights.

I need some help.



Hi @Les, have you tried disconnecting the power from the breaker for a little while and then seeing if the lights come on when it’s turned back on? This is great place to start. Make sure you’ve turned off the power from the breaker for at least 10 seconds before then turning it back on. Wait for the start up cycle to complete and verify the device is online in your Ring app. From there, turn the slider for “Lights” to the on position and see if the lights turn on. Let us know if this helped!

Thanks for the reply. Just got back from holiday so haven’t been able to try your suggestion as yet. WIll try it tomorrow and let you know.


1 Like