Kwikset 912

I have attempted several times to integrate my Kwikset 912 z wave lever lock into the ring system. However, I have been unsuccessful. I have placed the ring hub next to the lock, reset the lock, and hit the pairing button on the ring hub. I have another kwikset lock 888 that integrated on the first try. However, the 912 is not conducting itself in such a manner. Please provide me with any suggestions.

Thank you in advance for your assistance.

Hi @Derrn1 ! Have you tried replacing the batteries?

It was a brand new set of batteries but I will try that.

1 Like

Have you tried doing a Z-Wave un-enroll first then enroll the lock? I have had a couple of circumstances where I needed to perform the un-enroll function first for whatever reason. Also - call Ring support and talk with them on this. My experiences have been great working with support. I had a Yale lock that gave me some issues enrolling. Support walked me throuhg a couple of things (including the un-enroll first) and I was up and working in about 20 minutes.