[ISSUE REPORT] Two-way talk issue between Fire TV Cube (2nd) and Ring Doorbell 2 and 4

I have seen two-way talk are not working properly as expected between Fire TV Cube (2nd) and Ring Doorbell 2 consistently. These have been tested on 2x Fire TV Cube(2nd gen) and 2x Ring Doorbell2 and 1x Ring Doorbell 4. I have uploaded the evidence on youtube: Fire TV Two-way Talk Bug with Ring Doorbell 2 - YouTube

Issue 1. Shown in the video between 0:00 - 1:00, I used command “Alexa, show me front door”. Fire TV Cube managed to launch live view with the Fire TV Cube microphone off. However, when I want to enable 2-way talk by using remote to unmute microphone, the Fire TV Cube will immediately mute microphone back. Basically I cannot get 2-way talk working by using the remote.

I believe this is not expected as stated in https://support.ring.com/hc/en-us/articles/360017596112-Two-Way-communication-through-Amazon-Echo-devices

Issue 2. Shown in the video between 1:00 - 2:21, I used command “Alexa, talk to front door”. Fire TV Cube managed to launch live with with microphone enabled. And the two-way talk is working properly at the beginning. It also reminds me that the microphone will be automatically turned off in 30 seconds. However, after 30 seconds timeout, instead of disabling microphone and keeping live view open, the Fire TV Cube (2nd gen) just completely shut down the live view. I don’t think this is expected and I have to use command again to launch the live view.

I am suspecting this is likely a bug in Ring skills or possibly a bug in Fire TV Cube.

Happy to test any fixes if needed.

These are tested on

Two of Ring Doorbell 2 and One of Ring Doorbell 4

Firmware: Up-to-date at 18th/Dec/2022

Two of Fire TV Cube (2nd Gen)

Software Version: FireOS 7.6.1.4 (PS7614/3227)

Fire TV Home Version: 6410028.1

FYI, I am a software engineer and familiar with bug reporting mechanism. Please feel free point me to a proper bug report platform if there is one.

1 Like

Hi @relliky. Thank you for being detailed with your response and sharing a video example, that was very helpful in demonstrating exactly what you’re seeing. When using the command “Alexa, show me front door”, you should be able to hold down the mute button on your remote to enable the microphone. While the mute button is held down, the microphone should be active. Can you try that and let me know if the two-way audio is functioning?

@Caitlyn_Ring , thanks for a swift response. It’s a bit hard to see in the video, but I have pressed the mute button on remote about 20 times. Each time the unmute icon is back to be muted in about 0.3 second. You can see in the video that it’s sometimes have the green glowing ring around that button on the TV but then it stopped. That’s when it was unmuted from the remote by me and then automatically muted again due to the bug.

Let me know if you need me to record a better video evidence for this.

1 Like

Hi @relliky. I’m happy to chime in here. The next best step would be to contact our support team to investigate your concern further. Give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.