How to remove a Chime if it will no longer connect to wifi?

Hello - I have a Chime that will no longer connect to Wifi. (It’s physically damanged.)

So I’m trying to remove the device from the Ring app.

The only way I’ve found to remove a device is to go to Devices > [Chime Device] > General Settings > Remove Device.

But since this Chime is not connected, when I click on General Settings the only option I get is to “Reconnect Chime”.

There must be a way to remove a broken device that can’t reconnect, but I can’t figure it out. Any ideas? Thank you very much.

Hey @Jbajr. Is the Chime showing as offline in the Ring app? I have a Chime Pro (should be the same for Chime after double checking and as you stated in your steps) that was showing offline in my app so I went into the Main Menu > Devices > Chime Pro > General Settings > Remove This Device, and then got this message before I tapped Remove This Device again. Do you get this pop up as shown in my reply?

Thanks so much for the response.

Yes, my Chime is showing as Offline in the Ring app. And I can’t get it online again because it’s physically broken.

And my problem is that when I go to Main Menu > Devices > Chime, and then tap “General Settings”, I get the message in the attached screenshot: “2nd Floor and all devices connected to it are offline.” (2nd Floor is the name of the Chime in question.)

The only option is to “Reconnect Chime” - which I can’t do because the Chime is broken. (I have tried X-ing that modal (it just returns me to the screen underneath), going through the “Reconnect Chime” flow (there’s no way to bail on it to actually get to the General Settings screen), and I’ve tried everything else I can think over to actually get to the “Remove Device” option - in both the app and on the ring.com site.

I just can’t find a way to remove the device now that it’s permanently disconnected.

But there must be a way? Thanks so much for your help!

@Jbajr Thanks for much for getting back to me! I have to admit, this one is a bit odd and I’m unsure why the app will keep taking you through this loop. Could you try removing the Ring app from your phone, rebooting your phone and then reinstalling the app again? If this still persists, please take a screen recording of you trying to remove the device and that message still persisting. This will help be the evidence we need so I can get this escalated up further! In addition, let me know what phone you are running this on, as well as the OS version, as this will be information they need to know. :slight_smile:

Thanks very much Chelsea.

I deleted the app from my phone, restarted my phone, reinstalled the app, and am seeing exactly the same behavior.

I’m on an iPhone 11 Pro, OS 13.4.1, and the lastest Ring app.

I took a screen recording but this forum won’t let me attach an MP4 file. Let me know how else to get it to you if necessary.

Really appreciate the help - it’s surprising to say the least that there’s no way to remove this broken Chime… Thanks!

@Jbajr I won’t lie, it is surprising for me too! Thank you for capturing that screen recording. Since MP4 files cannot be attached, if you could try to compress the file into a ZIP file, this will be something you can attach. If not, feel free to email it to community@ring.com and I can upload it in a reply here for you. :slight_smile:

Thanks Chelsea. Here’s a screen capture of exactly what happens when I go to Menu > Devices > Chime, and then can’t get to General Settings because it’s no connected.

@Jbajr Thank you for this video, again! I have this escalated up to the appropriate teams and they are looking into this further. They have informed me that we should have this fixed in an upcoming patch of the app, and that this seems to be an issue specific to some iOS users. It was recommended that if you have the ability to use the Ring app on an Android device, that it should allow you to remove it on an Android device! Otherwise, if you do not have an Android device, no sweat. This should be fixed in the coming months, and I would say to just disregard your Chime in the app during this time. :smiley_cat: