History Edit Option

When I click on History, the edit option is not appearing in the upper right hand corner. I’m not able to delete my History all at once.

Hi @Jakenovi8812! Try swiping right on an event in the history list, which should result in delete options appearing. The delete all option will then appear in the bottom right hand corner. If this does not work, please remove and reinstall the Ring app on your mobile device, or check for updates. I hope this helps! :slight_smile: