Green recordings

Is there a way to stop some of the recordings coming out pure green? I’ve noticed my doorbell starts recording and after a few seconds it’ll blip into a green screen then record normally.

Hello Iaml3gend,
Try this.
Go to the device screen - tap gear icon on top right hand corner - tap Device Settings - tap Video Settings - turn off Colour Night Vision.
Hope this helps