Genn2 key pad lost connection

Hi so I have a second generation key pad. The red connection warning light can on last night on the pad. I’ve tried to reconnect the device but unfortunately it won’t reconnect. The battery on the pad is over 50%. I’ve removed the device and tried to re add it. During the reinstall it ask to connect the power connector. Usually the battery indicator comes on the screen but this time nothing and when I click on the app to say connected the process fails and won’t connect the device again. I’ve also reset the pad using a small pin in the reset button in the rear but again won’t connect. It’s less than a year old.

Hi @Memorex. Those were excellent troubleshooting steps to try. Try factory resetting it as well. To do so, follow these steps:

  1. Plug in the Keypad using the supplied cable and charging block.
  2. Press and hold the pinhole reset button on the back of the Keypad.
  3. Hold the button down for 10 seconds until the network LED flashes red, then release.

Try setting up the Keypad once more. We also have this Help Center article with other steps to try. If you have tried these steps and are still having the same concern, give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.