Gen 2 not recognising battery and offline

As of yesterday my doorbell has been offline and wont reconnect to my wifi. When i press the orange reset button there is no white spinning light. We have charged it overnight but now it also says to add battery and that there is no charge. When we plug it in it flashes blue a few times and then nothing. We have tried doing a reset by holding the button 30 seconds and tried different charging cables. Any ideas?

My Ring door bell is dead. It went offline yesterday. My phone ap says there’s 35% battery left.
When I try and charge the blue light flashes for a minute or so but then goes completly off.
Its about 18 months old. when I plug in the orange charge lead, the ble light flashes for about one minute again, then goes off. When I press the button nothing happens

Hi neighbors. If your Ring Doorbell is offline and not responsive, first try recharging the battery using the provided charging cable plugged into a standard power outlet. This may take about 6 to 8 hours. After the battery is fully charged, hold down the reset button on the Doorbell for 20 seconds.

Once the reset is complete, walk through a new setup in the Ring app using the steps under Set Up a Device. If this doesn’t work, and the Doorbell is still unresponsive, please reach out to our support team at one of the numbers available here for further assistance. You can also get in touch with our support team on Facebook @Ring.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.