GE Wall toggle switch won’t pair with Ring

I have a smart things Hub. It works in there, works with Alexa no problem too.
I can’t add it to ring.
It’s just stuck in pairing step, untill it says it was unsuccessful.
How should I do this to get it to work with Ring?

Hey @Jacoooooooo. In order for you to get the switch on your Ring app and to work with Ring, you need to have a Ring Alarm Base Station set up first, as the switch runs on Z-wave and needs to connect to the Base Station that also runs on Z-wave. If you do not have the alarm system set up or do not own one, you will be unable to pair the switch to your Ring app. For more information on what can be paired to the Ring app, you can get the full list here.

I do have the alarm set up and running. There is a base station for ring in the house. Still not able to pair the toggle switch with it. Had no problems pairing other devices to ring. On the other hand toggle switch paired with smart things just fine, but Ring won’t pair it.

@Jacoooooooo How is the switch paired to your SmartThings - through Z-Wave or WiFi? In most cases, it can only be paired to one hub at a time, so I would recommend reaching out to GE as the manufacturer to validate if it can be connected to multiple hubs at once.

1 Like

This is frustrating because there is absolutely no good information on how to pair a GE switch to Ring Alarm on this site or anywhere else on the internet. A few canned bot responses say to make sure you have your Ring Alarm set up. I do. Now what?

Can I please have step-by-step instructions on how to pair a GE Z-wave switch with Ring Alarm? Yes, I already have Ring Alarm set up.

I agree with Gburks. I would like the instructions to start with the type of device this switch falls under? Should it be set up as asecurity device? Sensor? Or what? There’s no category that describes it in the app? Where does it belong? Than, the next steps please. Manufacturer is sending back to the hub pairing procedure. The switch (toggle in my case) pairs by pressing it up once. The paddle switch is a little bit different, but still, ring wobn’t recognize it. Not a switche’s problem, as it’s being recognized by other devices, and not a multiple connection problem, because when unpaired from others ring still won’t pick it up.

Hey neighbors! In order to get your Works With Ring device to pair and add to your base station, you will need to do two things.

To get the set up process started in your Ring app, you need to go to the Main Menu > Setup a Device > Security Devices > Works With Ring. When you get here, you will tap “Add” at the button. Once you tap this, the Alarm Base Station will be “listening for devices” for one minute. During this time you will need to perform step two. This step is going to your Work With Ring device and putting it into “inclusion mode.” Once the device is in inclusion mode, and as long as it is close enough to the Base Station, it will find the device and add to the system.

If you are experiencing a hiccup during this process, it would be best to reach out to support at 1-800-656-1918!


The answer above worked for me. I did move my Ring base station close the new switch when pairing. All works perfectly.

1 Like

My problem was that I moved into a house where the previous owner had paired the GE toggle switches to his hub. Because they had previously been paired, they would not show up in the Ring app, even after performing the reset procedure (click up three times, down three times).

The only way I was able to unpair them was to buy a Samsung Smartthings hub, go to the Exclusion Mode setting in the SmartThings app, exclude the switch, and then it was available for pairing in Ring. At that point, I decided I liked the SmartThings hub better so I paired it with it instead.

The point is, Ring needs to add the Exclusion Mode workflow to their app, similar to the Exclusion Mode feature in the SmartThings app.

Have you figured out how to add the switch to the Ring Alarm base station yet? I have the same issue with the GE In-Wall Paddle Dimmer (14294). I followed all the steps, pressed Add, and then pressed the dimmer switch rocker, the screen changed from listening to new device to “device not found”, each time I tried to add the switch to the Ring and pressed the dimmer switch rocker. I am very frustrated now.

You have to have the Ring alarm base station very close to the device during setup.

Do you know how close is that? I tried to pair it within 3 feet between the base and the switch, and still have no success… My ring app does sense the trigger when I press on the dimmer rocker, however, the “device not found” message is immediately displayed and I cannot add the switch to the Ring system…

3 feet is fine.
Unfortunately, I dont have any other ideas.
I had a GE smart plug and took me 6 tries to get it connected and I wasn’t really sure why it worked the 6th time.

I’m having the exact same problem. I have tried the suggestion of bringing the base station closer and despite holding it literally 2’ away the GE switch is still not found by Ring and won’t pair.

The lack of troubleshooting and support information is highly frustrating. I think I’m going to return this switch and try one that works over WiFi with it’s own app.

There is an exclusion mode on the app. Go to devices, go into the base station device, go into advanced settings, underzwave a general remove device workflow is there.


Thank you for this suggestion. I tried in vain to use the GE procedure to reset the switch to factory default (quickly press ON three times, the OFF three times).

With the Ring Base close to the switch, I used the procedure described by you to remove/exclude the switch. Once this was done, I was able to add the switch using the Ring app. I also had the base close to the switch (about 1 foot away) during the ADD process.


This worked for me. I reset the switch, removed it from the base, and was able to successfully add the switch.

Once I switched my ring hub to wireless from a wired connection, then moved it to a foot or so from the in-wall GE Dimmer z-wave switch, then reset the GE Dimmer (3 presses on upper button and 3 presses on lower button), then removed the GE Dimmer from the other hub by going into the Ring App under the Base station, then Advanced Settings, Z-Wave and removed the single Z-Wave Device. Then I was able to add the GE Dimmer using the manual add option (+ icon) under Devices (in the left menu), then picked Security then “Works With Ring”. This allowed me to add the GE Dimmer Switch 46203. The GE Dimmer required me to press either the upper or lower button 1 time to be discovered when in the “Works With Ring” option in the Ring App.

Thanks for pointing me in the correct direction.

1 Like