Floodlight Cam Wired Plus No Live View

I installed the latest gen of the floodlight cam wired plus and cannot get a consistent live view. 90% of the time it wont show me the live view. I have a beast router - ROG Rapture GT-AX11000 | Gaming Routers|ROG - Republic of Gamers|ROG USA

I get a strong connection all the way to the end of my driveway and for some reason this cam on my garage seems to have issues. Under device health my signal strength is RSSI - 53 which i understand to be a great connection.

I purchased that wifi chime pro thinking it could just need an extra boost, and my cam wont connect to it, saying that my router has a better connection. I don’t think the signal strength or internet speed is the issue.

Could this be happening because my router is blocking something? I have restarted the router and super frustrated not being able to see the live view. Any help would be greatly appricated.

Also note that I have arlo cameras throughout my property, further than the floodlight, and they have had zero issues.

A Chime Pro is a great addition and solution for extending your wifi network, however, it may not be necessary with the router you have. As it looks like you have a robust and advanced network, this should come with tons of features and UI options for optimizing your network performance. Here’s our Help Center article for an overview of which ports and protocols Ring devices use.

An RSSI of -53 can indicate some interference or distance impacting signal to the Camera, the Chime Pro should help with this. Moving your router closer to the Camera and prioritizing it, if possible, to an antennae is worth a try.

Sometimes live view connection concerns may seem related to your network, but could actually be due to mobile device variables. I recommend trying out the Rapid Ring app, designed for optimal access to live view. Please also ensure there is not a vpn enabled on your mobile device. :slight_smile: