Floodlight cam wire plus set up

Well, this has been an interesting one.

My electrician installed a new RING Floodlight Cam Wired Plus for me today - but the device is not playing ball at all.

When the installation was completed - I started the set up process and it looked like things were going to plan - device booted up, I went through the steps on the RING app - so far so good - App got to the part where it wanted to install Firmware - this completed - “Great” me thinks - nearly there - however since this was done - the camera is not working, and I am constantly getting “Device Offline” errors. I’ve tried holding down the button on the top of the device, for a brief two seconds, and also for the longer recommended 20seconds - sometimes this seems to put the device back into setup mode - and other times it doesn’t.

I’ve been through the entire process above several times now, with no success whatsoever. The camera still isn’t working - still getting “Device offline” errors. A couple of times I have also noticed that the light on the camera has flashed green instead of the usual blue - really not too sure what this means. I have also tried rebooting my Virgin Media hub, in case there was a problem with my Internet connection - again, this has not rectified the issue at all.

Any advice appreciated. I have other Ring devices set up at home - did not have any issues at all with these, however the outdoor camera is a different story.

Thanks for reading



Hi @AlexBG. What is the approximate distance between your Floodlight Cam and the router? There could be something causing interference with the signal, preventing the Floodlight Cam from maintaining a stable connection with your wifi. Do you see a number listed for the RSSI under the Device Health screen in the Ring app? This might give us an indication of the signal strength before the Floodlight Cam disconnected.